Snowmobile Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Guys I need some help here. Have a 96 Yamaha VK540 II and it has always been a great running sled. We use it for grooming our local trails each year. It has always been a very dependable machine. Just went to start it and no spark. The kill switch doesn’t really click loud on/off like most switches do so I thought that could be the issue. I removed the cover over the handle bars and disconnected the switch from the system (this should take the switch out of the system) and still no spark. Disconnected the TORS system and still nothing. I pulled the ignition coil off of my 94 VMax 600 and tried that on the VK540 and still no spark. A few years ago our local shop did a ton of work on this sled and one part was to repair some wiring that had shows some signs of heat. So I checked their repair and it looked good. Wanted to check all the simple things first and now I’m down to the CDI unit or coil. Is there anyway I can check these? I don’t think it’s a ground issue either because the ignition coil mounts directly to the engine. If I there is now way to check the CDI or coils I might just pick up a CDI unit and see if that fixes the problem. Does anyone have an electrical schematic for a 96 VK540 II that they could text to me? Any help would be greatly appreciated. Just trying to avoid a bringing it to the show where I know it will cost a lot of $$ just to get looked at.

Thanks guys,
Kyle ( the "Yooper", from the Upper Peninsula of Michigan, eh!)
 

·
Registered
Joined
·
1,562 Posts
And this is where we miss @yamadad4 as he would know right off the bat! Also KCCats is good with Yamaha as well.

Where at in the UP out of curiosity and which County?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Have you started with bypassing the switch and kill switch and the carb switches
Yes I disconnected the kill switch to bypass it and also the TORS (Carb) switches and no spark. Checked all the simple stuff that I know of. Just want to make sure there isn't something else simple before I look at the stator and CDI box.
 
1 - 7 of 7 Posts
Top