Snowmobile Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Runs and goes good once started but it's hard to start so I use the electric start. After riding It for about 20 30 minutes it seems like it gets hot and wont move. I let it sit for like 5 minutes and it runs good again. And what's the best way to flush the antifreeze. Thanks for the help
 

·
Registered
Joined
·
1,440 Posts
Welcome
Don't bother with the anti freeze, find a coil from a good running sled and swap it out
The coil when it gets hot may be breaking down and loosing spark?
 

·
Registered
Joined
·
3,447 Posts
Skidoo and their brilliant mounting of the CDI on those sleds </sarcasm>. Just inches away from the muffler. I put an aluminum shield over the top of mine and it doesn't overheat anymore.

But when you say "It doesn't move", are you saying the motor is still running and the sled won't move? If so, is it acting like the brake is engaged? If so, that points to a bearing issue, possibly the drive shaft.

Unfortunately, there is no clean way to flush the antifreeze that I have found. To drain, remove the lower hose, and prop the rear of the machine up. If you can devise some way to catch all the antifreeze, more power to you. I usually throw a tray under the machine and let it drain out into it and then clean up the mess afterward. When refilling, raise the front of the sled up so the engine is higher than the back of the tunnel.
 

·
Registered
Joined
·
3,447 Posts
BTW - These 583's are cantankerous cold starting engines. 3 primes crank until it fires and keep your hand on the primer and throttle to keep it running. You can hear a change in the engine sound when it will idle on its own, usually 2-5 minutes depending on outside temperature.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I will try swapping the coil with a good one and let you guys know. The kid I got it from said he put whatever he could find in it for antifreeze brake fluid oil anything flushed it out pretty good before winter came
Thanks for the help.
 
1 - 5 of 5 Posts
Top