Snowmobile Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Last time I loaded up my sled after a hard days ride, I hit the kill button and as the motor was winding down I heard a loud "bang". Sounded like a XT500 backfire, if anyone remembers those...

Started it back up and it was very loud, figured one of the exuast springs broke and the pipe seperated, checked them all and there are all tight.

Heres the goofy thing, the exaust leak is coming from the canister (right side of the canister if you are sitting on the sled)

Theres a door on the side of the canister with a spring , if I open the door i can see packing....

Wtf is this??? stock?? someones home brew way to repack and canister, maybe the spot welded it shut and the backfire blew it open??
:confused:
Any ideas thanks!!
 

·
ride till your broke
Joined
·
2,560 Posts
x2^^ i wana see this!!!
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
well its snowing here now, so might take it out later today. Should not be an issue with the back pressure if im not holding it wide open right?

Will post pics asap but the q is how safe is the motor with out the canister backpressure?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
Well I shot some rivets in as a temporary, but will end up getting a used silencer... anyone in WI have one of these??

The pictures look like it cracked once before and the previous owner tryed to fix... Sled has almost 10,000 miles on it, runs perfect, never been let down :cheeky4:
 

Attachments

·
ride till your broke
Joined
·
2,560 Posts
wow. ive seen that done on clogged cat convertors,
but never on a sled can!!
 
1 - 9 of 9 Posts
Top