Snowmobile Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
hey there new here but read a few posts already, just wondering if anyone could help with my rxl just started acting up today idling too high (pushing 4000 rpm) then when i touch the throttle it wants to bog out but before this happened had it out for a drive and worked great for about 15 minutes then started bogging and when i stopped it bogged right out and shut down!

any help would be great thanks
 

·
Registered
Joined
·
36 Posts
Discussion Starter #2
would the tps be the cause of this? should i just replace it with another one to see or what should i do??
 

·
Fool Injected
Joined
·
210 Posts
Do a quick search on here and you will see many posts of the same problem ... Start with battery voltage and work back to the charging system and wiring.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #5
ok the tps sensor code is showing up what do i use to check it or test it and what should the numbers be when i test it to show its good or bad?
 

·
Registered
Joined
·
36 Posts
Discussion Starter #6
alright boys i got the sled working decent but not the best it idles fine and there are no codes coming up on the computer but there still is a slight bog until i hit about 5500-6000 rpms so when slowing to go around a turn or just turning the sled in generally is tricky to keep the rpms up...also have a light like squeal off the take off now so im thinking the secondary? should i adjust to see if its better?

any help would be great
 

·
Registered
Joined
·
54 Posts
Mine bogs abit, Ive learned to deal with it because when she hits 8400 rpm it sings. Get a new belt before playing with anything.


Watch my vid and see if yours sounds the same


 

·
Registered
Joined
·
36 Posts
Discussion Starter #8
yeah sounds kinda like it i guess haha but i just put a new belt on it and as for the squel when im starting to take off id think that would be from the secondary am i correct? and what belt do you run on yours?
 

·
Registered
Joined
·
36 Posts
Discussion Starter #9
the squel is only as im moving slow like 10-20mph i just dont want it to wear anything out or whatever im just trying to be cautious with it...so if i go up the field and slow down to turn while im turning it squeals a bit worse
 

·
Registered
Joined
·
54 Posts
I havent even looked at the belt, the sled was mint when I bought it so just oil and gas. At what rpm does it engage at? Maybe pass some 600 grit sandpaper over the clutch faces to take the shine off it. Could be something in the secondary but try the sandpaper first.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #12
on gas squeal and yeah i just bought this one too and it was running awesome until yesterday and my belt was worn out so i got a new one and put it on cause i thought that was the problem but now it squels haha i dont know i was just thinking the guy i bought it from adjusted the clutch and turned it all the way up so that it would tighten the worn belt a bit...just what i was thinking
 

·
Registered
Joined
·
36 Posts
Discussion Starter #13
engages about 4500-5000
 

·
Registered
Joined
·
36 Posts
Discussion Starter #15
yeah a bit i can see if i have any fine sandpaper here..and try that and i wouldnt even touch the primary i dont think did you notice what color your spring is in your primary? mines blue.. but as far as the secondary there are 4 holes for your spring to go in i know that much but would need help on which way to put the spring..(if spring is in the second hole do i move it left to the first hole or to the third or fourth?) so exclude the squel i should loosen the clutch shouldnt i?
 

·
Registered
Joined
·
54 Posts
Think its blue. I just put a Cudney Racing clutch kit in my Skidoo and WOW! Well worth the $$$. Up next is to find a kit for the Poo.

Honestly I havent a clue where you could move it. Old spring might not even have an effect as it should when moved around. Is it possible to make a vid of the sound?
 

·
Registered
Joined
·
36 Posts
Discussion Starter #17
yeah would love to get a kit for mine or a racing clutch or something for the sled i bet she would scream haha but yeah never thought of the spring itself inside the secondary..that could very well be wore out as well
 

·
Registered
Joined
·
36 Posts
Discussion Starter #19
4600 miles
 

·
Registered
Joined
·
54 Posts
Would you have the tools to take the primary and secondary off the sled? Maybe take them off and have a look and see if theres something wrong.
 
1 - 20 of 33 Posts
Top