Snowmobile Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Got this mint '91 RXL SKS with 17000 miles, the motor has never been opened and has good compression, 120 psi across the 3. I believe both the primary and secondary clutches are bad even though the motor gets to 8400 rpm real fast and has tons of torque but it takes awhile for the sled to gain actual speed.

Could someone suggest a good clutch kit? Got an radar race comming up next month and I'd like to see how fast it goes.

 

·
Registered
Joined
·
612 Posts
Well, if you are just lookin for a higher RPM engagement ,spring & weights will help that & secondary adjustment.Also your chaincase gearing will help lowering it for that top speed quick ,lift off short quarter mile run that you striving for.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #4
Not sure what Im looking for honestly. Took the RXL out today, I'll upload some vids tonight so you can hear whats going on. When I let off the gas you can hear an odd whining sound coming from the secondary, like its closing too fast. Has awesome power right till redline but just doesn't seem to have that pickup and go feeling.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #5
Heres 1 of 3 vids from today. If you listen to the sound the sled makes when I let off the gas you'll hear it whine. Not sure if this is normal or not. Uploading more to UT and will post when they are done.

 

·
Registered
Joined
·
54 Posts
Discussion Starter #7
So I take it nothing can be done to stop the noise then? After so many miles would the clutchs need work?
 

·
Love/Hate
Joined
·
6 Posts
I've had nothing but love and problems with my 91 RXL. I think I'm currently experiencing round 2 of a stator issue. New battery and I got 17 miles on this thing before it started to backfire, followed by it bogging down with a fistful of throttle and then dies. Charged battery out of habit and ran like a champ. Will run tomorrow to see if I can duplicate. Any pointers?
 

·
Registered
Joined
·
54 Posts
Discussion Starter #9
The original owner I bought this from said there were never any issues with anything on this sled. Serviced regularly at Polaris, other then having to charge the new battery he gave me, it starts on the 2nd pull and runs good other then a bog when I punch it. The sled is mint but I did go over all the grounding points.

Have you checked to see that the battery is actually getting a charge from the motor?
 

·
Registered
Joined
·
612 Posts
You stated that it has 17000 miles ,I'm assuming that it's actually 1700.0 miles,correct? With that sled being in that condition 120 PSI in all three cyl. & engine never opened ,it's very unlikely it has 17000 miles.
Anyway ,if your belt isn't top notch then you might have a issue of bogging in the first 100ft !? The belt should be about 1/16 to 1/8th of a inch above the secondary sheave .The wining noise that your hearing is common when your braking ,(like BC Dan mentioned).
I would try changing to a new belt first then let's see how it's performing,then take it from there.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #11
Its 17K miles. All service records indicate this to be true, went to the dealer which is about .5 kms from the gentlemans home to verify. The belt does sit low in the secondary, will order new one on Monday.

 

·
Registered
Joined
·
612 Posts
Wow! So that thing actually has 17000.0 miles on it ? That thing looks in almost new condition ! That guy took good care of it then & drove it lots!
 

·
Registered
Joined
·
54 Posts
Discussion Starter #13
Once in a lifetime find. It was his retirement gift to himself. Hes 78 now and cant pull it over so he bought a new sled with reverse and E start. Dealer knew that the front shocks were done which I used to bargin the price down to 500$ from his 800$ asking price. It came with the manual, all service records and every gas/oil/plug/hotel purchase bill. It was his baby as he put it.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #15
If it runs and you have fun on it, does it really matter what it looks like? I just need to find some extra speed somewhere to keep up with the newer sleds or sell my 2 sleds and get something abit faster.



 

·
Registered
Joined
·
43 Posts
If your in ottawa I have a clutch with the "weights" to engage at 5K rpm if you need something out of it. I'm in Carleton Place. It's a take off of my 91 650, the inner sheave is junk so the clutch is useless, it's got the big red spring in it too.
 
1 - 16 of 16 Posts
Top