Snowmobile Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
350 Posts
Discussion Starter #1
so i got a lot of history with this sled... my bro picked it up 5 years ago w parts in a box, rotary valve was lunch meat and had messed up pistons and jugs... we ended up getting the brass gear for the valve and two used jugs that were .050 over plus had to get pistons n gaskets... well it ended up in my cousins hands for a while and it was running good, then last year it was missing real bad so i checked it out for him and found the suction hose for the fuel pump was loose on the engine (which goes to the magneto side) and just flopping around. so we fixed that and checked comp. it had none on the mag side so just assumed that he melted a piston... so now i picked this sled up from him for $100 but i also got a helmet w a heated shield to boot... so the deal was good... i got the engine apart and its bad... i was right the piston is melted but not just a hole in it.... these pistons have two ring and the top ring groove and ring is gone its all imbedded in the head... so just wondering if anybody has any ideas as to what kind of problem im chasing. there was a misterious needle bearing sitting on top of the pston when i tore it apart its only like 3/8 of an inch long so it is not a bearing from the wrist pin bearing... it kind of appears to me that the oil pump stopped working, but the one side looks a-1.. but as i was dumping the oil from the rotary valve i had oil coming from the crankcase on the pto side so i believe that the inner seal was leaking and helped protect that side. so does anybody have a theory as to why this did this...
 

·
Registered
Joined
·
350 Posts
Discussion Starter #2
Anybody???? i wld like to start the repairs i plan on splitting the case and atleast replacing the outer seals so just wondering if anybody has had similiar isues and actually figured out what made it do this
 
1 - 3 of 3 Posts
Top