Snowmobile Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
547 Posts
Discussion Starter · #1 ·
I have an 82 skidoo citation that i juss bought.it ran perfect.i brought it home sat in the driveway for a week and i moved down to the shed. about a week later i hooked up a tailight to it.I started it up and it would idle fine and when i gave it some gas it would bog out. Can someone please help me.
Corey Pratt
 

·
I am Spartacus
Joined
·
23,863 Posts
Did you actually check for spark? Ground the side of the plug against the engine and pull it over. It should have a bright blue spark and you should be able to hear the snap sound. If no spark or it is yellow in color, it's probably the CDI.
 

·
Registered
Joined
·
1,299 Posts
when you hooked up the taillight where did you hook up the wire?
you might have created a short somewhere, the sled runs fine at a idle but when you give it the gas the in creased out put from the mag. could be jumping to the short. try running it at night
IN THE DARK on and see if you see any sparking going on anywhere. under the hood or anywhere around the wiring. hope this helps, good luck!!!
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #6 ·
no i can't see any sparks comin from any of the wires...i gonna replace all the fuel lines,,and get a fuel pump rebuild..see wat happens after that.
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #7 ·
i think it's the carb...when i take the needle valve out it won't idle but when i give it trottle it takes a sec and it will rev up...mabe the needle seat is bad or somthin like that
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #9 ·
i got it running it was the needle the c clip had fallen off so it wasn't givin it the fuel it needed...thanks for the suggestion though..wat kinda citation u got 4500 or 3500 i had the 4500 and the track got all screwed up and couldn't find another one so i got a 3500 with my 4500 motor in it....hopen to get it runnin this weekend
 

·
King of the Universe
Joined
·
6,674 Posts
HillBellyCustom,
Ever get that Citation running?? Still looking for a track? I got a 80 MotoSki Mirage II (identical to SkiDoo 4500) with a new 0-mile track on it. 377 single carb Rotax which ran good when put away 5 years ago. (Sled had primary clutch problems). Need to get it out of my garage located in Northern Lower Mich. Interested?
 

·
Registered
Joined
·
547 Posts
Discussion Starter · #11 ·
yea i got it running...i bought a body of a 3500 and put my 4500 motorin it..i would be intrestec in the motor but u live pretty far away...let me know wat u want for it and u'll think bout it
 
1 - 11 of 11 Posts
Top