Snowmobile Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 96 600 XCR SP. I purchased it from my uncle who is an avid rider, much more than myself. I do not talk to him any more and I'm wondering what modifications he did to the sled. Everyone I talk to says the 96 XCR SP's are a little slow out of the hole but in a straight line can expect to push 115 mph. That is not the case with mine. Mine is a rocket out of the hole but will only push between 90 and 95 mph top end.

Can anyone clue me in to what are the likely modifications he did to it? Something to look for?

Thanks!
 

·
Registered
Joined
·
354 Posts
Easiest to check is the clutching, a sticky secondary may not be letting the belt go down far enough to give you the top end you're looking for, or it is possible the gearing in the chain case is set up for acceleration, which will drop your top end. With a sled of that age, I would give both clutches a good cleaning and checkup, and see if that helps.
 

·
Registered
Joined
·
570 Posts
Lets get to the bottom of the real problem here. Why don't you talk to your uncle any more? If you could patch things up with your family you could get your questions answered correctly and not have to guess about it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Sorry for the poor wording, I was trying to spare everybody on here from reading my life story. If I knew where he lived that'd be great. He'd probably help me with it himself but unfortunately he divorced my aunt and moved away. I don't think he even lives in Michigan anymore.
 

·
Registered
Joined
·
29 Posts
My buddy just picked up a 95 xcr 600 (short track) in excellent condition. I dont know what was done to the engine but it is scary fast. He got a box of parts with it and there is the stock head sitting in the box....and there is a new wiseco sticker on the sides (I dont think he would have those unless they were in the engine). I took it for a ride yesterday and cranked up 60mph in about 120ft w/o studs going down my long drive. And out in the 400yd field I got it up to 90mph no prob at all with lots of field left to decell not using the brakes. Stinkin' fast. The original owner said there is a "19" gear on the top that he put on for good midrange....and that it does.




Ryp
 
1 - 5 of 5 Posts
Top