Snowmobile Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
HI, Wondering if anyone can help me with this:
377 skidoo safari, single carb. Machine will run and idle IF I continually use the hand primer to inject gas (not a fun way to ride...) Fuel in the OUTLET side of the fuel pump (which is new) only rises a few inches in the line and wont make it over the crest into the carb. If I take the fuel OUTLET line off at the carb, hold it in a can and start the machine fuel get freely pumped. Hmmmm.. No obstruction or leaks in the vacuume hose from the engine block to the fuel pump. No leaks in the fuel line either. This leads me to believe that the problem has to be inside the carb, meaning something in there is "blocking" the ability of the pump to pump fuel. I dont believe there will be ice since shop was heated and machine was inside all this time. The pilot air screw and idle screw are both "set" at the numbers of turns specified in the clymers manual. Before I tear into the carb I would appreciate any input from the experts- thanks dave
 

·
Registered
Joined
·
365 Posts
hey

Just had the same problem with my 1990 Safari 447 LXE.

I had to replace the throttle cable anyway, so i pulled both needle valves out.. They were quite clean, so I reseated them. I did however notice that the fuel filter input line was quite degraded at the conectino. I replaced the fuel filter, replaced the line and bingo. Sleddin' all night long!


Same thing happened to me with the primer though. Would idle if continuously primed.

HOwever, i'm far from an expert, so good luck to ya!
 
1 - 3 of 3 Posts
Top