Snowmobile Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
1st: i put back together a 377 dual carb fired it up today, first i made sure there was no air leak put hand over one carb motor stalled fired up again put hand over other carb motor stalled adjusted idle it sounds like it's running right but my six sence was telling me no it's not so i pulled plugs one was hot the other was not so i touched cylinders one was hot the other was not so i switch coil wires and swithced sides with plugs and yet again one side was not firing right. switched coil wires back put in new plugs and one side is still not firing. sorry i'm not very good on what they call the side that's not firing it the cylinder beside pull start or oil pump. i'm going to check compression on that cylinder later, i replaced pistons and rings but nothing to cylinder maybe that cylinder is over sized meaning worn out
2nd: if the one cylinder was not firing why would it stall the motor when i put my hand over carb

p.s. this motor is cdi
 

·
Registered
Joined
·
168 Posts
Wouldn't hurt to check compression. How is the plug on the cylinder that is cold when you pull it out? is it dry or wet? Seems as if its a fuel issue also check fuel delivery to the carbs. I had a weak fuel pump that would only pump enough fuel to supply 1 carb
 

·
Registered
Joined
·
142 Posts
Discussion Starter #5
everthing is brand new from inline filter to pump to carbs well i just cleaned carbs so i will clean carbs again closer i'm going to switch carbs to see if cylinder will fire with the other carb and check compression also it's definitly going to be one or the other when i pulled plug on the bad cylinder there is nothing like it was brand new
 

·
Tinkerer
Joined
·
384 Posts
Your problem is most likely in that carb then. I cleaned a carb one time and my hands were a little dirty and it ran worse than before i cleaned it, maybe thats what happened?
 

·
Registered
Joined
·
142 Posts
Discussion Starter #7
ok update i switched sides on the carbs now the other cylinder does not fire so it's a carb problem i pulled the carb off and gave it the simple test first carb right side up blew air through gas inlet that works put it upside down i couldn't blow air through that's good i kept blowing air through turning it upside down and right side up i was doing this back and forth and the needle was working properly with that test so i dropped bottom of carb off to expose needle & seat i started blowing air through the inlet again right side up i was controlling float lever manualy and it was working, when the float lever was level there was still very little air going through i had to lift the lever up slightly and it closed completly how level should the floats be when they completly stop gas flow and if they are not closing completly will this make the cylinder not fire like flooding itself or is this still a jet problem
 

·
Registered
Joined
·
168 Posts
was there gas in the carb when you took it off? I had an issue similar to this and it wasnt the carb. Im not saying that that carb isnt plugged up or something but seems like a fuel delivery issue.

Is the plug wet on the cylinder that isnt fireing?
 

·
Registered
Joined
·
142 Posts
Discussion Starter #9
yes there was gas in the carb i have the carb torn apart right know to give her a cleaning again when i put back together i'm going to switch fuel lines to see if rebult pump is working right
 

·
Registered
Joined
·
168 Posts
and if the cylinder that is not fireing has a wet plug then id say that there is either crap in there so the needle isnt closing or its bad
 

·
Registered
Joined
·
142 Posts
Discussion Starter #11
i'm going to put on sled right now and i put a new needle and seat in i will let you know in a few
 

·
Registered
Joined
·
142 Posts
Discussion Starter #12
nope still the same and that carb is clean i switched fuel lines didn't make a difference i tried to take for a boot but there was no power like one cylinder not firing i switched coil wires nothing, here is the mystery when the sled was running i stuck my finger in the carb to lift the bowl up and it reved up how can it do that when it's not firing because the dame plug is not hot like the other???????
 

·
Registered
Joined
·
142 Posts
Discussion Starter #14
what ever you call it the bowl that lifts up when you pull on the throttle cable it reved up when i lifted it i'm going to check conpression tomorrow WOW what a mystery
 

·
Registered
Joined
·
168 Posts
does it run ok when you rev it up? sounding like the idle circuit is not passing fuel maybe the idle are screw is not adjusted correctly
 

·
Registered
Joined
·
142 Posts
Discussion Starter #16
i put the choke on two pulls it starts 5 seconds i take the choke off and it idles ok but i can tell it's not running on both (i think i'm not crazy) there is gas shooting out exhaust lots of smoke as for the idle screws i have both set at 1-1/2 turns i'm going to switch sides with the carbs just to make sure it's carb problem and do a compression test
i'm not sure what you mean by idle circuit
 

·
Registered
Joined
·
142 Posts
Discussion Starter #17
ok i made sure it was a carb issue the carb in question i switched side with other carb and it didn't fire on that side so it's a carb issue i cleaned 3 times, i forget who posted carb cleaning pictures for all the jets because i got to be missing something it's not a pump issue because i switched lines also there's plenty of gas getting to both carbs what else could be wrong with this carb not firing i'm just about ready to convert to single carb
 

·
Registered
Joined
·
168 Posts
well if gas is shooting out that means its getting too much fuel and fouling out the plug i would put in new needle and seat in both carbs they do go bad over time
 

·
Registered
Joined
·
142 Posts
Discussion Starter #19
the carb in question does have a new needle and seat it's got to be firing when i stick my finger in the carb and lift the slide it revs up
but why is one side hotter than the other
 

·
Registered
Joined
·
168 Posts
well if its fan cooled then naurally the cylinder farthest from the fan will be hotter

indeed sounds like the idle jet is plugged still
 
1 - 20 of 26 Posts
Top