Snowmobile Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I was stopped for a safety check in VT last weekend and realized I had no brake light. It turnes out that it works only some of the time. Obviously check the brake switch on the handle bar but the shop manual doesn't say how. Any Help ?
 

·
Registered
Joined
·
170 Posts
if it works some of the time its probobly just a corroded bulb. (very common) remove 2 phillips head screws from tail lite, pull cover,bulb removes buy pushin it in alittle turnin counter clockwise. polish 2 lead bumps on back of bulb w lt sandpaper and reinstall or new bulbs are cheap (1157 auto bulb will work) and i bet your all set
 

·
Registered
Joined
·
794 Posts
you can take the micro switch apart on the handlebar and sometimes it is possible to clean it and get it working again but most times it is so corroded that the switch will need replaced. You have to take the switch housing apart to get at the brake switch the one with the hi/lo beam and rer switch in it. there isnt much to the switch its just a small spring and a sliding contact. The dealer gets about $60 for a new one.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Found the problem, took the brake handle off with 1 bolt, behind it is a little micro switch. Sprayed it with a little W-D, worked the switch back and forth a little with a small screwdriver and WALLA, Fixed.:D Thanks for your responses. The dealer actually helped me over the phone.
 
1 - 5 of 5 Posts
Top