Snowmobile Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
I have a 2001 Skidoo Summit 800 STD. Never had any problems. A couple of weeks ago, decided to put a 7" riser extension on by Powermadd. The install went flawlessly. I did have to splice in additional wires across all harnesses, put on an extended brake cable and a throttle extension. Everything went smooth. The machine stated on the first pull.

Now, on my second ride after doing the extension, all of a sudden my machine died and there is no spark. Just before, my handlebar rotated because it wasn't tight enough. I was concerned that perhaps I had pulled one of my splices loose. I had used crimped splices waterproof heat shrink connectors.

Well, I pulled everything apart and inspected my wires. They all look perfect. So I no longer think that a wire was pulled.

I next thought to just check the kill switch to see if it was the problem. I don't know how to bypass it on this machine. There are three wiring harnesses so I have tried pulling them to open position each individually, and no impact.

How can I bypass the switch for a test? Any other ideas? Does anyone have a wiring diagram for this sled?

Thanks in advance!
 

·
Registered
Joined
·
50 Posts
Discussion Starter #3
Thanks for asking that question. I did not have a reason to question the teather because I never remove it. I did look at it after your response. Seems fine for connecting. Not sure how I might test that. Seems obvious that it is electrical. Sure hoping that it is not a stator or CDI issue. Not sure where to troubleshoot from here.
 
1 - 3 of 3 Posts
Top