Snowmobile Forum banner

21 - 31 of 31 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #22
NVM I found a picture of it. Seems that no one sells one even aftermarket. It does 31 liters as that is all I can find. I did find a rebuild kit though on eBay for it.

Also it seems Yamaha used the same pump, and the pumps are made by Mikuni. Yamaha part # is


picture of it



Personally at that price I would rebuild it for 12 bucks first before spending 90 dollars. Also what Yamaha does on some of their sleds with that pump is us two of them bolted together.
That pump only has one key for carb I need 2. Rebuilt out today and seems to not wanna prime rafter got sled started
 

·
Registered
Joined
·
1,164 Posts
Idk at this point BearAK is the Ski-Doo guy here. I hate rebuilding fuel pumps but then again mine only cost 16 for aftermarket and 27 for OEM Mikuni's vs 12 for a rebuild kit. Sent him a DM maybe he has another one or can point you towards another one.
 

·
Registered
Joined
·
3,621 Posts
Does this sled have a choke or primer?

If it has a choke, do yourself a favor and add a primer.

If it does have the primer, what is your normal starting procedure? Should be:

3 squishy primes
Pull until it fires
Ready with the primer to keep it running.

If it doesn't fire, then hold throttle at 1/4 throttle and pull.

If that still doesn't fire, remove plugs and look at them. Are they wet? If not, put them back in, prime 2 more times and pull until it fires.

If the machine has sat for a while before you're attempting to start it, you can pressurize the gas tank to force fuel into the carbs. I usually use an air compressor and my hand around the gas inlet.
 

·
Registered
Joined
·
3,621 Posts
ps. It takes about 2-3 minutes of priming to keep it running and get it warmed up enough to run on its own. Bit longer when it is cold out.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #26
It’s choke with no primer. I’ve only had it couple weeks and replaced carb manifold and new choke cable and plugs. Today I put new choke cable on and it started after I put fuel in the spark plug holes. After I turned it off it wouldn’t start again and plugs are Wet. Changed plugs and still won’t fire
 

·
Registered
Joined
·
15 Posts
Discussion Starter #27
One of the outlet tubes on fuel pump is not in best shape and about to break so that’s why looking for replacement pump but can’t find one. Closest thing I found is this one. It’s different but thought that it’s same concept from what the dealer said here which they have been no help
65155
 

·
Registered
Joined
·
1,164 Posts
This is the one I use and is the upgraded model from that one. Same one I use now on my sleds and they are Polaris, Polaris used the one you have from factory back in the '80s to the mid '90s, they are the same just that one is a flush mount is all.

 

·
Registered
Joined
·
15 Posts
Discussion Starter #29
21 - 31 of 31 Posts
Top