Snowmobile Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I need some help guys....

The last few times I have ridden me sled about 5 minutes into riding I start to hear a loud ring or squeal coming from the clutch side. It continues until I let off the throttle then it goes away. I also dont hear it as much at high speeds.

Any suggestions of what it might be?
 

·
Registered
Joined
·
170 Posts
due to the fact you say noise is only at certin rpms i would start w a basic clutch cleaning. first blow compressed air in and around primary and secondary.(black dust everywear)spray break cleaner in primary and secondary.hit w air again. spray alittle quality teflon,oil,or silicone lube in primary rollers. rag w soap and water to clean oil residue off belt contact area. if surface has belt scuffs or wht residue steel wool or lt sandpaper,before the soapwater.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I took the primary off, cleaned it with compressed air and brake parts cleaner, Still makes the squeal. So I took the secondary off and the bearing on that side. Going to replace those tonight and see what that does.
 

·
Registered
Joined
·
170 Posts
good call on bearin. i figured clutch cuz only made noise sometimes but could be a harmonic squeal. hope thats it. and while your at it put some cleaner and lube in that speedo cable just for the fun of it.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top