Snowmobile Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
213 Posts
Discussion Starter #1
Hey all, long time no see. Well two days ago I got my ski-doo out and got it all ready and when I went to start it, the pull cord snapped, I got my spare pull cord out of the compartment and this will be the first time replacing it, can anyone give me a step by step plan on what to do, because I had some problems with this before when my brother tried to fix it.

Thanks for the help :)
 

·
Registered
Joined
·
315 Posts
remove the recoil housing
untie the rope
tie the new rope on .
rewind the spool. there is a notch in the spool to accomidate the rope as you are rewinding it .
now is when you need to run the recoil in and out several times to ensure the tension is proper. dont wind it too much , but enough to rettract the rope every time
then i tie a bunch of temperary knots together so the rope doesnt go back into housing
re-install the housing on the engine
once again make sure the rope retracts properly, sometimes the bolts on the housing can cause it to bind up so start the bolts and just snug them . if it is still working properly, then tighten the bolt and run the rope through the loops or where ever it goes to tie on the handle , tie on the handle
there you go !!
hope like mad the spring is not broke because if it is ....... well it REALLY gets fun !!!
we will cross that bridge when we get there :)
 

·
Registered
Joined
·
213 Posts
Discussion Starter #3
Thanks for the help man, sadly I need to get a new part, im gonna get it tommorow hopefully, again thanks for the steps :thumbsup:
 
1 - 3 of 3 Posts
Top