Snowmobile Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi everyone iv got a 1995 polaris indy trail 488 fan. It will start fine with the choke but will not idle (bogs after a few with the choke off dies quick with the choke on) When running it with the choke on it has great to end but bogs out when stopping and with the choke off it dies when full throttle is used (better performance when you let of the trottle slightly) anyone have any suggestions for this im not very good with two cycle motors. Thanks and sorry for the long post
 

·
Registered
Joined
·
12 Posts
Discussion Starter #2
Well i cleaned the carbs really well and that seemed to do the trick. The only problem is it still will bog at WOT. It cuts out them comes back and i can figure out why. The idle is up and the air screw is 1 and 1/4 turns out. I could really use some help with this. Thanks
 

·
Registered
Joined
·
101 Posts
Well i cleaned the carbs really well and that seemed to do the trick. The only problem is it still will bog at WOT. It cuts out them comes back and i can figure out why. The idle is up and the air screw is 1 and 1/4 turns out. I could really use some help with this. Thanks
Check your fuel filter. I had a similar problem where the fuel was not coming through the filter fast enough at WOT.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
I have already replaced the fuel filter and the plugs on it. According to the sticky on lean vs rich its running rich. I hear popping in the exhuast and it runs better when its cold and only does this when its warmed up and runs worse with the choke on.
 

·
Registered
Joined
·
92 Posts
You may need to look into new coils. Running great cold and bad warm is one of the symptoms, and the same problem that I too am having right now. Well one of my many problems with the sled!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
It will hit that when it is cold but as soon as it warms up it bogs out and pings in the exhuast. Sometimes it bogs really bad and other times it will come back with a little more throttle. It runs best when the throttle is not Wide open like about 3/4 throttle. Low end is great all the time so i got that right at least but what eltse needs to be adjusted.
 

·
Registered
Joined
·
101 Posts
What do the plugs look like after you run it wide open for about a minute? Are they dark or cocoa brown or very light brown?
 

·
Registered
Joined
·
18 Posts
check the needle and seat in the carbs, had the same problem with my brothers 90 sport 340 both were worn pretty bad replaced them and its golden
 
1 - 9 of 9 Posts
Top