Snowmobile Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
ok ill start buy saying i own a 05 rev renagade and love it

however my wife owns a 1994 mxz 470

history of the sled 2000 miles been rebuilt 2 times !
i bought it with a fresh motor rebuild and 4 hours into it a a rist pin let go and did alot of damage .

bought used good heads and pistons along with a rebuild crankshaft.

last week i took the sled in for a tune up they cleaned and synced the carbs. blead the oiler and replaced my plugs. I had them do a compression test and it was 100 lbs clutch side and 145 on mag . with new spi pistons that had like 1 hour on them , I think they will break in as i had the cylinders honed out.

so the first day i take it out it ran great for about 1 hour then it started stalling with you are not on the gas and it runs ok full trottle. I thought it was over heating so i blead the coolant and even took out the thermo stat and boiled it on the stove to see if it was opening. it was. took the fuel lines off and there is no fuel coming out ! so i ordered a new fuel pump and new lines as on these ski doos they are under the motor and i do not want to pull the motor again ! im going to mount it on or under the airbox. when i put gas in the sled it will not start up.. only everyonce in blue moon.. how to test to see if i do not have a bad crank seal .

please help me on this one as ive got well more than anuff money into this sled!!
 

·
Registered
Joined
·
1,182 Posts
Spray carb cleaned around the seal when it's running and see if it revs up.Is the oil pump working properly??Make sure the carbs are not mixed up.The mag side has a larger main jet.
 
1 - 2 of 2 Posts
Top