Snowmobile Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I just rebuilt my 1993 Indy 500 EFI and in the process of pulling the flywheel I messed up the magnets (long story). The local used parts shop had a flywheel from a 1994 Indy 500 EFI, it has a different part number but looks identical. I put it on and re assembled my Indy but now have no spark. The fuel pump buzzes as normal but no spark. Anyone know if the 1994 flywheel is compatible on a 1993?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #2 ·
Anyone know how to test the stator/coils? I'm thinking I fried them when I heated up the flywheel with a torch...
 

·
Registered
Joined
·
1,057 Posts
no spark

i have 650 efi when i first got it i had little problem similer to that but it wasnt the shop told me if someone took flywheel off they might of broke the keyway in there sometimes will start but not get enough spark morelike it wouldbe skipping hope thishelps
 

·
Registered
Joined
·
608 Posts
Anyone know how to test the stator/coils? I'm thinking I fried them when I heated up the flywheel with a torch...
Sounds to be a likely cause.

exciter coil.... br/w to blk/r 164 ohms


lighting coil ...y to brn..... .2 to .4 ohms


battery charge coil gry to gry/w .2 to .4 ohms



The stator is different on a 94 EFI.
The 93 came with a 200 watt alternator and the 94 had a 250 watt alternator
Don't really know what else is different but the magnets on the flywheel are surely not the same


It may be possible to use the 94 flywheel if you also use the 94 staor assembly... will have to research that......
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
The exciter coil is showing no ohms, its open. I guess it's fried. Are these interchangable on a bunch of machines?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
I changed out the 1993 Stator with the 1994 one. 1994 has one extra wire, a Brown and white one coming from the magneto. I wired the rest of the plug to fit my machine and just deleted the brown and white wire. It works great!
 

·
Registered
Joined
·
1,057 Posts
no spark

to mrholmquist r u a im assuming a sled machanic by trade or just seen alot cause u sure do help alot of people out on this forum and its great to see this not counting the money u have saved us all :cool:
 

·
Registered
Joined
·
608 Posts
I am a diesel mechanic by trade. I have been a sledder for years and I do my own and service a select group of friends sleds. thanks for the appreciation. :D
 

·
Registered
Joined
·
1,057 Posts
i have 1995 650 efi rxl no major problems yet runsgreat only 1 in my area with efi on older sled so people always ask me ? but if i cant answer them i send them to u keep up good work
 
1 - 10 of 10 Posts
Top