Snowmobile Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just got this sled love it but when I first start it's like it's running on one maybe 2 cylinders if I feather the gas I can get it eventually after 3-5 mins to pick up over 2 grand and it will run just fine but I just found out today I got ballzy and when I started it and it bogged I pinned the throttle it dogged for a second then it was fine did it twice works better then trying to feather it to get it out of the dogg is what's weird is it's only when u first start it everytime u shut it off it dose it but once its started and out of it it runs fine any ideas would be awsome also got new battery so that's not the problem
 

·
Registered
Joined
·
1,032 Posts
Look at the computer for the heck of it and see if it has any flashes. Also that EFI system was horrible, there is a reason so many people switch them over to carbs. I have the same system on my '92 Indy 500 EFI and I am switching it over to carbs because every time I get one thing fixed on it something else breaks 2-4 weeks later.

Also those have fuel filters on them as well. DO NOT buy the Polaris one though as you can get the same thing from any auto parts dealer. The part number you need is a equivalent of a Fram G4777.


Anything that you can get at your local parts store that is the same as this will be the same fuel filter. I had to replace mine when I bought it and that is what I did. Found it online someplace and it worked perfectly.

Also there is a regulator that will go bad over time. I had to replace mine as well YEARS ago and there is one from a car as well that will work. The part number from Nissan is 2267038U00. Someone else posted that number within the last couple of weeks. I found it a different way but it is the same part on all the RXL's and EFI 500s


Something to look at as I didn't get any codes when I was having issues and I took a gamble with those parts
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Look at the computer for the heck of it and see if it has any flashes. Also that EFI system was horrible, there is a reason so many people switch them over to carbs. I have the same system on my '92 Indy 500 EFI and I am switching it over to carbs because every time I get one thing fixed on it something else breaks 2-4 weeks later.

Also those have fuel filters on them as well. DO NOT buy the Polaris one though as you can get the same thing from any auto parts dealer. The part number you need is a equivalent of a Fram G4777.


Anything that you can get at your local parts store that is the same as this will be the same fuel filter. I had to replace mine when I bought it and that is what I did. Found it online someplace and it worked perfectly.

Also there is a regulator that will go bad over time. I had to replace mine as well YEARS ago and there is one from a car as well that will work. The part number from Nissan is 2267038U00. Someone else posted that number within the last couple of weeks. I found it a different way but it is the same part on all the RXL's and EFI 500s


Something to look at as I didn't get any codes when I was having issues and I took a gamble with those parts
Thanks man gave me some things to look at the guy I got it from went thru the tank seat was not bolted back on at all so I know he did it the tank inside has new lines I need to run new outside gas tank but ya I'm not kicking any codes I unhooked the sensor in the air box and it Immediately kicked the code so I know it's working it's just weird once it's out of the bog it's fine but shut if off warm even and it starts right up but has a bog if I shit can it it it dogs for a second then comes right out of it and it's fine till u shit it off it's odd just never had a efi sled so I know nothing about efi had 500+ yamha exciters and polaris indy and xlts triples but nothing like this only got it because I'm sick of pulling my ass off to start my sled it's a 91 polaris rxl 650 touring 2 up but I wanted the better suspension being a 2 up and it's a individual triple unlike my xlt so Easyer to rebuild so I got it owned a 580 efi arctic cat that was a pile of shit battery kept dieing and sled would not go over 15 mph home it sucked so I was taking a gamble with this sled lol
 
1 - 5 of 5 Posts
Top