Snowmobile Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi I have a 1990 artic cat jag 440 afs. When I start it it will run great for like 5 minuets then will start cutting in and out. At low rpm it's better but doesn't want to raise. Then like when it's builds up gas in the bowl it will go again full throttle for 500 feet then cuts out again. I have cleaned the carb, new feul lines and vacuum line, cleaned the gas tank, new spark plugs, it seems to run better when it's like 7- out but when it's over 10 above it does it. When it starts cutting out I can shut it off. U have to use the choke to get it started again but it will go like 500 feet. Plz help
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3 (Edited)
I took the feul line that runs from the feul pump to the carb and there seems to be plenty of feul coming out
You have any other recommendations? Thanks
 

·
Registered
Joined
·
3,588 Posts
When it cuts out, does it die completely? If it does, does it start right back up? When it starts cutting out, can you put the choke on to keep it alive?

If you lift the track off the ground and just rev it up to half throttle, does it want to cut out after a short time?

Can you blow into the fuel tank vent line and it is free and clear?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Some times it dies completely but it will start right back up with full choke then take it off when it starts. Sometimes when it starts acting up if you go like 10 miles per hour it runs great but it won't get any higher until you have drove slow then it will ripe for 500 feet. It doesn't do it when it's on the stand. Only when it's moving or driving. I can fill throttle it and it will get right up to 80 mph and runs great but when you take the stand off to try it it will start cutting again. Blowing into the vent line don't change it at all. Thanks
 

·
Registered
Joined
·
182 Posts
If all else fails, take the fuel pump apart. I had a Polaris that would did the same thing. I found that there was a chunk of ice in the fuel pump that formed from water in the fuel. Removed the ice, put the pump back together, and it ran great.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
It does that at full throttle in out and back in. If it is the problem do you know how to fix it? Thanks
 

·
Registered
Joined
·
10 Posts
I would definitely check the fuel pump membrane, and replace it even if it looks fine.
A good cleaning of the carburetor is also a good idea, specially the main nozzle.
 
1 - 14 of 14 Posts
Top