Snowmobile Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
took it out and ran boggy after an hour of riding it boggy it opened up and was very fast then made a stupid decision and messed with the carb and started doing it again what is going on?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
settings on carb are set back to what they were before its almost like the crankcase is full of gas or oil would this cause a bog issue?
 

·
Registered
Joined
·
75 Posts
have you cleaned carbs and is fuel fresh have you recently transported on trailer w fuel on sounds like most likely a fuel issue but could be clutch but less likely
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
yes have cleaned carbs and changed fresh fuel but the thing is it ran perfectly fine after the ride like it eventually burned something out of there that had been sitting there and doing it again like after i pull on it for a while like something is getting to much fuel in it or oil and takes a little to get burnt off its not the carbs i don t think and definitely not the clutch.i was at a buddies and adjusted the carb and ran like crap til i got 20 minutes away and all the sudden opened up weird?
 

·
Registered
Joined
·
75 Posts
yeah that sounds pretty wierd check the choke plungers it sounds like it may be overfueling then catching up once u get on it give it a hard run then kill it immediately and check plug color
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
yes i have did that a couple times checked both and adjusted the carbs at my buddies house and it was still boggy but better so i proceeded to go to my house and about thirty minutes later after i left his house and was riding home is when it decided to open up and was good after that than messed with the carbs but pl,aced the screws back to the same settings they were at when it ran good.the plug is wet but was at my buddies house also like it is getting alot of gas somewhere and needs to burn off?
 
1 - 6 of 6 Posts
Top