Snowmobile Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1 (Edited)
hey iv got a 1982 ski doo citation ss 377 dual carb the motor seems to be running fine but i can only do 50mph dose that seem slow for that sled if so dose any one kno what my problem may be ? though the sled could atleast do 60 70 but maby not thanx
 

·
Let it Snow!!
Joined
·
229 Posts
When you get it going as fast as you can does it seem to bog out?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
no not at all it seems to rev fine but i thought it would go faster then 50 my cosin has a 250 elan and it will do 45 i dont think my clutches were changed but ill have to see what the stock springs are
 

·
Let it Snow!!
Joined
·
229 Posts
clean the clutches. What you can do is take the chain case cover off and put a smaller sprocket on the bottom. You will gain top end and go faster but also lose bottom end though.
 

·
Registered
Joined
·
40 Posts
Haha, i had the same sled! you have the yellow or black cowl? all ive ever seen besides mine was the black so i thought the yellow was cool...ANYway, my top speed? 50mph...:laugh:

That thing is NASTY out of the hole though, isnt it?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
yeh she is pretty fast takin off witch is fun cuz i use it in the woods alot so im not top end very much and shes got the orange hood on er hah think they only made it the one year everyone thinks its a moto ski when they see it but the moto skis had 2 sets of vents in the front mine only has the 1 set on the right hand side
 

·
Registered
Joined
·
121 Posts
Yes that is slow, I ride with many sleds with the 377 twin and they all do 60 mph,and there the single carb ones.

Back in the Day I had 1980 300 Yamaha Enticer going 55mph across a lake and a 4500 Citation(single carb version of yours) went by me buy at least 5mph.

A 300 single Tundra II can almost hit 50 MPH.

Check the compression of each cylinder.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
i think its my clutches or carb cuz somtimes if i let it come up to speed slow and at like 3 quarters put it to the bar it will rev right up and i got it going 70 but if i put it right to the bar off the start it only revs so high and thats it
 

·
Registered
Joined
·
2 Posts
i think its my clutches or carb cuz somtimes if i let it come up to speed slow and at like 3 quarters put it to the bar it will rev right up and i got it going 70 but if i put it right to the bar off the start it only revs so high and thats it
What was your problem, the clutches? I'm having the same issue
 
1 - 10 of 10 Posts
Top