Snowmobile Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
i have a ski doo citation that will not run right. it has good spark, but now it seems like it is getting too much gas. gas shoots out the carb when i get on the throttle. i would realy like to know what carb goes on it. think maybe the carb is too big. runs for about 20 minutes and wants to die. please help!! any suggestions apreciated.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
also where should the idler and air screw be set. runs fine but idle gos up and down. when taken a distance and opened up, wants to die. squirting the primer will keep it running temporarily. plugs get a little flooded and dark.
 

·
Registered
Joined
·
142 Posts
sounds like carb problem needle stuck open or fuel pump could be bad fuel leaking in impulse line as for you idle screw start at 1-1/2 turns out
 

·
ZR rider
Joined
·
2,064 Posts
The adjustment isn't the problem here if it's jumping around. Your floats are probably sticking. Clean the carb and let us know how it goes.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
ok, carb is clean, but not sure about the fuel pump. how do you test it? how does it even work? thanks for the help. could it be bad crank seals? had a buddy suggest it.
 

·
Registered
Joined
·
142 Posts
there is a line that comes from motor to pump that's the impulse line this is the vacumm line when piston goes up and down it creates a vacuum which in turns moves the diaphram in pump to move up and down which pushes gas to carb rebuild it only cost $8
as for the seals get some ether (starting fluid ) spray around crank seals if you can get it to run long enough one side at a time if it revs up your seals are bad
 

·
Registered
Joined
·
143 Posts
I my pantera did that once and I was puzzled too. I would hit the gas and all it did was spit gas out the carb and back fire. I thought it was fuel related too. It turned out to be one cylinder was running. If your still havin trouble start the sled on one spark plug then the other. One of mine didn't fire but fixed and runs good.
 

·
ZR rider
Joined
·
2,064 Posts
Check the compression.
 
1 - 9 of 9 Posts
Top