Snowmobile Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All, I'm new to the forum looking for some invader advice. Just bought a 1978 to get running again with my son. I read the fuel is 89 octane leaded fuel. Granted this is from 1978. Will the modern 91 non oxy hurt it? What plugs should I run in it. I'm thinking BR9ES.

Any help is appreciated.
Just got it home last night, ist priority is getting the engine unstuck.
 

·
Registered
Joined
·
216 Posts
You will be fine on the gas, and should be on the plugs. The John Deere version of that motor uses that plug as a cross reference to the Champion N2C. That was the stock plug back in the day. What plug is in it now?

On those old Kawi motors. Replace both crank seals. They go bad and leak as they age. You can get aftermarket seals real easy.
 

·
Registered
Joined
·
1,563 Posts
Yep those were known for it. I put probably 2 sets of seals in my old '82 Arctic Cat Panther within 3 years because of that issue.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
You will be fine on the gas, and should be on the plugs. The John Deere version of that motor uses that plug as a cross reference to the Champion N2C. That was the stock plug back in the day. What plug is in it now?

On those old Kawi motors. Replace both crank seals. They go bad and leak as they age. You can get aftermarket seals real easy.
It has 9’s in it. Also has a hole in the mag side cylinder. I only paid $75 for it. 1100 original miles. It’s in pretty good shape and it’s all there. The track is free. Good project sled.
thanks for all the help.
Bob
 
1 - 4 of 4 Posts
Top