Snowmobile Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
My 2005 XC 700 the dec light will flash when you really hammer on it, But it only will do it 1 out of 25 times you really get on it. I have premium gas in it and it is fresh. Cleaned the exhaust valves. I did switch the plugs from factory champion to ngk BPR 9 es this is what the dealer told me to run. Could it be the plugs? Or what do you people think?
 

·
Registered
Joined
·
615 Posts
should run champions but thats probably not going to change it.todays gas is terrible with the ethanol try putting some star tron in your tank see if that helps but 1 out of 25 times is pretty good some sleds do it almost everytime you hold it wide open.but i would put it to bad gas does it do it when your key is on reg or prem.try running it on reg see what happens.
 

·
Registered
Joined
·
100 Posts
just try that along with the prem setting.. thats what worked for me.. its just spark knock.. it scared the crap out of me the first time it came on.. and it did it for a few rides until i figured out what it was.. i thought i was melting it down. haha
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
same thing here just bought the sled and the light was blinking thought it was going to blow it up the sled only has 1500 miles on it
 

·
Registered
Joined
·
100 Posts
yeah mine did it with 1000miles on it when i put on my twin pipes... talk about heart attack being about 60miles from the truck on two track!
 
1 - 8 of 8 Posts
Top