Snowmobile Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I've got a 2000 XC 500 getting around 7 mpg. top of piston and plugs are both wet and black, I've cleaned the carbs , moved the needle one notch leaner. I'm not a sled mechanic, but know my way around an engine. running all stock. any ideas? I know this sled could and should get twice that mileage. clutch is good, belt is newer, track is adjusted right. I've searched this site and found alot of others with the same problems, but haven't found any solutions. got mikuni flat slide carbs. at high end it will sometimes cut out, doesn't seem to reach top speed like it should. sometimes backfires when starting cold. feels like I need to "clear it out" when starting from a stop even when warmed up.

:dunno: please help!
could someone list exactly how to clean the carbs just in case i'm missing something?
 

·
TRH- Troll Raising Hell
Joined
·
6,133 Posts
You won't get much better than 11. I rode mine hard and almost always wide open and I averaged 7-9.

Try new plugs! There is a how to for carb cleaning.

Oh, and snowmobiling is spendy so suck it up, enjoy it for the 3 months, then save money all summer for fuel next year.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
still lookin for an fix

ok I TOTALLY took the carbs down to nothin and cleaned them, one post said to put in new plugs.... DUH! I put new plugs in every time I ride because they are so fouled and wet.
I ordered some new reeds, mine didn't really look bad but now i'm down to just throwing money at it.

I know polaris didn't get the best mileage right from the start, but 6 mpg?!?!
 

·
Registered
Joined
·
55 Posts
I have two XC 500's and my wifes sled gets horrible milage. Went for a ride on Sunday and filled up both sleds put on 60 miles and the wifes sled was 1/4 of a tank....not sure what that equates to in milage but the sled runs great no problems. I ride way harder than she does and I was at half a tank....if it's not broke I'm not fixing it I'll suck it up and pump the gas as long it runs and rides nice.
 

·
Registered
Joined
·
12 Posts
Had one great sled but sucked fuel. Go down a jet size move the clip one notch.Ride it hard for 10-15min CHECK your plugs. It helped on mine but still liked it's fuel.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
OK so I put the new reeds in, checked the choke seats, and cable to make sure they were closing and sealing, checked the Jets- 370's, closing and sealing nice, put new plugs in. seems to be running good, we're heading up the north shore lake superior this weekend, so I'll see how the mileage is. hoping the reeds take care of it!
 
1 - 8 of 8 Posts
Top