Snowmobile Forum banner

carberator

  1. Yamaha Snowmobiles
    I’m working on an 03 mountain max, hasn’t been run in a few years, got the carbs cleaned up, replaced plugs and I’ve got good fuel in there. I’ve checked spark and I’ve got heet in the tank to account for any bad gas or water still in the lines. It starts up easy but won’t run smooth, it doesn’t...
  2. Polaris Snowmobiles
    Hey they all, I was given a box of junk and it contained 2 carbs and oil pumps from what I believe to be a 90s era Polaris. I am trying to get rid of them and maybe make someone's day on their rebuild but I genuinely have no idea what these carbs belonged to. None of the items are marked with...
  3. Engine / Drivetrain
    Ok so our 2002 RMK 800 just won't stop being a huge pain, it has had this idling problem since we got it a few weeks ago where when it starts, it idles fine but over like 10 seconds just loses power, even if you are giving it a bit of gas. I cleaned the jets but didn't do any tuning, which...
  4. Ski-Doo Snowmobiles
    Hi everyone Son tells me every year it's hard to start,I have bad shoulders he doesnt Tried quick start to no avail and have spark Pretty sure it was rode hard and put away wet I bought it from him a few years ago but him and his friends still had it All i know is he always ran premium fuel...
  5. Yamaha Snowmobiles
    Just bought a 95 vmax 600 (my first sled). The idle after giving it throttle is very high. Is this too much of a lean mixture problem? How could I solve this issue?
  6. Polaris Snowmobiles
    I got a 2003 pro x 600 for very cheap.. in decent condition with just under 2800miles has good compression, spark, and seems to have fuel as the spark plugs are wet when you pull them out... is getting air aswell it seems.. it will run for a bit when you pour gas down the cylinders but then die...
Top