95 skidoo formula z 583 - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 10-04-2019, 05:20 PM Thread Starter
Registered User
 
Join Date: Oct 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
95 skidoo formula z 583

Has gas getting to the carbs but wont start will start for a second with gas down the heads but dies out after it burns out? Cleand the carbs and the jets and still nothing. Any help would be awesome.
Trippy929 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 10-04-2019, 06:39 PM
Super Moderator
 
BC_Dan's Avatar
 
Join Date: Jan 2004
Location: oregon
Posts: 16,641
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 196 Post(s)
I would pull a fuel line and put it in a container and pull the rope a few times. If no fuel, check the fuel pump, it may need rebuilt or the impulse line from the crankcase to the pump may have cracks in it.



If you have fuel in the container with every pull of the rope, check the inlet needle/seats of the carbs to make sure the needles aren't stuck in the seats. That is very common with sleds that have sat for a while. The gas in the bowl evaporates and the stuff left over turns to varnish and will glue those needles closed.


Welcome to the forum!

2017 SKS 800, 2007 Dragon RMK 700 155", 2008 RMK 600 155", 95 Prowler 550 2-up, Really OLD AC Cheetah

http://www.avalanche.org/accidents.php
http://www.kbsnowdrifters.org/
BC_Dan is offline  
post #3 of 8 (permalink) Old 10-05-2019, 07:52 AM
Registered User
 
Join Date: Sep 2018
Posts: 1,086
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 62 Post(s)
Go threw the fuel pump and at least clean it
Then replace all the fuel lines including the pick up in the tank
KCCats2 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 10-05-2019, 10:49 AM Thread Starter
Registered User
 
Join Date: Oct 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
It seems like it wants to start but just not getting any gas plugs are dry everytime unless I put gas down the heads. Just put new gasket in the top end.
Trippy929 is offline  
post #5 of 8 (permalink) Old 10-05-2019, 11:16 AM Thread Starter
Registered User
 
Join Date: Oct 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I put my hands on the back of the carbs and it's not sucking my hand towards it. It's just not pulling gas.
Trippy929 is offline  
post #6 of 8 (permalink) Old 10-05-2019, 09:25 PM
Super Moderator
 
BC_Dan's Avatar
 
Join Date: Jan 2004
Location: oregon
Posts: 16,641
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 196 Post(s)
Have you checked the compression?

2017 SKS 800, 2007 Dragon RMK 700 155", 2008 RMK 600 155", 95 Prowler 550 2-up, Really OLD AC Cheetah

http://www.avalanche.org/accidents.php
http://www.kbsnowdrifters.org/
BC_Dan is offline  
post #7 of 8 (permalink) Old 10-06-2019, 05:28 AM
Registered User
 
TheBearAk's Avatar
 
Join Date: Jan 2011
Location: North Pole, AK
Posts: 3,295
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Ha, this is simpler than that. The 583 is a cold b_tch to start and keep running. Even at 70 degrees, it won't start and stay running on the first fire.

95 will have a primer. After priming, usually 3 priming, then pull the primer out and pull start it. When it fires, get your hand on the primer and get ready to prime. As soon as the motor starts to die, push the primer in. Keep your hand on the throttle and on the primer and prime to keep it running. Usually takes about 3-4 minutes running for it to run on its own. 5-10 minutes when it is really cold.


You have to be quick with the primer. Don't prime before it starts to die, otherwise you will flood it, but prime as soon as it starts to die or it can be to late.

2015 Skidoo Renegade BC 600 Etec
1999 Skidoo Summit X 670 HO (Son's)
1996 Skidoo Touring E 380F (sister's)
1995 Skidoo Summit 583 LQ
1985 Skidoo Tundra 250F
1999 Arctic Cat Jag 340F
1999 Arctic Cat Z 370F (son's) - needs track
1990 Arctic Cat Jag 340F
1982 Arctic Cat Panther 440F
TheBearAk is offline  
post #8 of 8 (permalink) Old 10-06-2019, 08:10 AM Thread Starter
Registered User
 
Join Date: Oct 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Got it running switched the gas tank out. Still really hard to start when cold tho.
Trippy929 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome