Snowmobile Forum: Your #1 Snowmobile Forum - Reply to Topic
Thread: Starter drive hits flywheel at high RPM Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-01-2019 08:42 PM
bullrder33
Quote:
Originally Posted by TheBearAk View Post
Waking up a 9 year old thread here.

1st thing is check the spring. Even put in a stronger one. Most electric rebuild shops will have a decent selection.

The other thing would be to put some shims between the starter and the bracket. Maybe move it away 1-2mm and see if that helps.
I did change the spring and it seemed to help a little but not totally. I heard they make a heavy duty spring for them but I haven't been able to find one yet. Didn't realize how old the thread was, I was just looking for answers, figured it would have been answered by now. If I find the correct fix I'll be sure and share.
04-11-2019 01:37 PM
TheBearAk Waking up a 9 year old thread here.

1st thing is check the spring. Even put in a stronger one. Most electric rebuild shops will have a decent selection.

The other thing would be to put some shims between the starter and the bracket. Maybe move it away 1-2mm and see if that helps.
04-10-2019 09:00 PM
bullrder33 I'm having the same problem with my 04 ski doo gsx 600ho. It only comes out and hits at high rpm it will start moving and popping out hitting fly wheel.
01-14-2010 09:29 PM
smallengineguy You said you replaced the spring with a new one? Maybe install 2 springs?
01-14-2010 08:46 PM
Ultrafrozen 7000 rpm could be just the right vibration frequency to make the bendix/ pinion bounce against the spring to hit the ring gear. Make sure all the starter bolts are tight and the motor mounts are in good shape. This might be enough to dampen the vibration.
01-14-2010 07:16 PM
Dirk Diggler
Starter drive hits flywheel at high RPM

Hi,

I am hoping someone can help me. I have a 2006 GTX and last year I was getting a strange noise when at around 7000 RPM. I brought it to the dealer and they told me the starter drive was vibrating out at high RPM and hitting the flywheel so they took off the end cap, the spring that forces the starter drive back in place after the engine has starter and the bendix/starter drive. The snowmobile worked fine all winter and I just used pull cord. I replaced all the parts this summer but the same thing is happening (only at 5k or higher RPM...not at idle). There is only about 1/4 gap when the starter is not engaged - is this normal? There seems like there is quite a bit of tension on the spring to hold it in place so it seems strange that it is vibrating out. Is there something else that could be wrong? Is there anything I can do?

Any help is greatly appreciated.
Thanks!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome