Clutch grab - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-30-2019, 09:20 PM Thread Starter
Registered User
 
Join Date: Feb 2019
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Clutch grab

I bought a couple of new Polaris belts and installed one of these belts and I am having a problem with the belt grab. My model has the one way bearing between the clutch sheaves. When I engage the throttle the belt climbs up the sheaves normally, but when I let of on the gas the belt does not return to the center bearing properly. I seem to jam outside of the groves and push into the engine side clutch sheave causing the belt to be engaged at all times. This makes it impossible to shift out of gear without shutting down the engine. It's almost like the belt is too narrow, it just will not return to the groves of the center one way bearing. Do you have any insight as to what may be causing this?

Thanks for you time,
geolimbo is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-31-2019, 06:28 AM
Registered User
 
Join Date: Sep 2018
Posts: 975
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 58 Post(s)
Welcome!
I belive most Polaris driven clutches have the 3 screws to adjust the belt tension.
It is just set for the old belt and needs to be loosened for the new belt.
You will want to tighten it back once this belt wears in.
KCCats2 is offline  
post #3 of 4 (permalink) Old 05-31-2019, 06:30 AM
Registered User
 
Join Date: Sep 2018
Posts: 975
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 58 Post(s)
KCCats2 is offline  
 
post #4 of 4 (permalink) Old 06-01-2019, 01:43 PM
Registered User
 
Join Date: Nov 2018
Location: In Marinette County, Wi
Posts: 344
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Not all Polaris sleds have those 3 screws, the older styles did not.

What exact model and year is it? That will help out a lot.
Coolhand is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome