Oil consumption - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-15-2019, 12:12 PM Thread Starter
Registered User
 
Delbo's Avatar
 
Join Date: Mar 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Oil consumption

2005 rev 800ho 2600 miles all stock. Started useing excesive omount of oil . no leaks. , 132 psi cluch side 136psi mag side. Use .5 gal in 80 mile. Help please.
Attached Thumbnails
Click image for larger version

Name:	20180213_132544_1552669957846.jpg
Views:	18
Size:	42.1 KB
ID:	62946  
Delbo is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-16-2019, 08:07 AM
Registered User
 
Join Date: Sep 2018
Posts: 987
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 58 Post(s)
Welcome!
Sounds like your oil pump is stuck on wide open!

You may have to pull the carbs? (good time to check the boots for cracks)

The oiller cable bay just be out of the spliter too?
KCCats2 is offline  
post #3 of 5 (permalink) Old 03-16-2019, 12:12 PM Thread Starter
Registered User
 
Delbo's Avatar
 
Join Date: Mar 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Arm in pump looks to be operating fine. Dont understand cable comment.
Delbo is offline  
 
post #4 of 5 (permalink) Old 03-17-2019, 09:06 AM
Registered User
 
Join Date: Sep 2018
Posts: 987
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 58 Post(s)
The cable has a splitter and the oil pump cable may have poped out and now wont let the arm go fully closed?
KCCats2 is offline  
post #5 of 5 (permalink) Old 03-17-2019, 11:02 AM Thread Starter
Registered User
 
Delbo's Avatar
 
Join Date: Mar 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Checked the splitter and every thing is good there. Took cable off of arm and arm is closing all the way.
Delbo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome