Yamaha 250 bravo - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-17-2018, 08:20 AM Thread Starter
Registered User
 
Join Date: Mar 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yamaha 250 bravo

Hi I have a bravo long track and drive down the trail with slid in tow going to the cabin. I be driving about 5 min and start to loose power. The when I let go the gas she will shut off. Seams like she getting air locked? I try to prime her but she pick it up onless I take out the spark plug. That seams to on air lock her. Then I can start her up and go again. Also when that happens thereís a line the goes for the tip on the gas tank to black container that rubber banded on the back of the dash. This line fills full of gas and the container. None of this happens when the skidoo is up on a Stan. She spin over good and lots of power.
Matthewburry99 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome