500 V Max needs help - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-19-2010, 03:23 PM Thread Starter
Registered User
Join Date: Feb 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
500 V Max needs help

1997 V Max 500 When at a idle about 2500 rpm you can hit the gas runs fine wide open whatever. When you get off the gas and rpms get between 3000 & 4000 engine just starts blubbering choking, giving it gas nothing helps must let it sit until rpms get below 3000 then runs fine until you let off the gas again. This does not happen every time but enough to be frustrating. Have changed fuel filter and used Sea Foam lost on what to do next.
jackjudy is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-20-2010, 01:17 PM
Registered User
Join Date: Oct 2006
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had a similar problem. The secondary clutch would stick and not let it downshift until the rpm’s got real low. It was like trying to take off in high gear. I cleaned the clutch and everything worked fine.
w muller is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome