1990 Phazer 2 - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Yamaha Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-14-2009, 12:39 PM   #1 (permalink)
Registered User
 
Join Date: Dec 2009
Posts: 1
1990 Phazer 2

I have a 1990 Phazer 2 and it runs good when I have the choke on but when I take it off it bogs down and wants to die when i give it alot of throttle. I took the plugs out and only 1 of the plugs is hot. I tried new plugs and it does the same thing. Anyone have some ideas on what the problem is? I have used fresh premuim gas. I guess maybe some water could have gotten in the tank but I dont know. Thanks
Mirkofedor is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-14-2009, 01:18 PM   #2 (permalink)
Trevor
 
YamahaSS440's Avatar
 
Join Date: Apr 2009
Location: Wisconsin
Posts: 4,124
Try cleaning the carbs again and make sure all fuel lines are clear and arnt blocked.
__________________
2009/2010 Miles:900
2010/2011 Miles:1300
2011/2012 Miles:530
2012/2013 Miles:1050
YamahaSS440 is offline   Reply With Quote
Old 12-14-2009, 01:21 PM   #3 (permalink)
Yamaha 4 Life!
 
TheSnowPro's Avatar
 
Join Date: Mar 2009
Location: Coldwater, Ontario
Posts: 582
im having the same problem with my 89. im thinking fuel pump.
__________________
Mine - 1989 Yamaha Phazer 485 w/ Comet 102C and boyesen power reeds. 14,356 kms.

Dads - 1997 Yamaha V-max XT 600 stock w/ polaris P-85 clutch

Brothers - on its way home soon! either a yamaha or skidoo. not sure what yet.


First ride of the 2009/2010 season - 11/12/09
09/10 km's - over 1200. pretty good for only half a seasons worth of riding.
TheSnowPro is offline   Reply With Quote
Old 12-14-2009, 01:22 PM   #4 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 32,102
A cold plug means that it is not firing at all.
If you switch the wires from one plug to the other, does the problem follow the wire?
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 12-14-2009, 09:21 PM   #5 (permalink)
Registered User
 
Join Date: Nov 2009
Posts: 12
i had the exact same problem on my 1991 phazer 2! what it came to be was a broken wrist pin! so i ended up having to get new rings and getting the clyinder bore honned out, but make sure u clean the crabs..the phazer 2 air intake it behind ur clutch so it does suck in alot of belt dust and stuff and no foam to stop it. it was about a $400 job with parts and labor. ohh when u do run it what is ur top speed mine was only like 45mph till it got fixed
fuzz is offline   Reply With Quote
Old 12-15-2009, 11:42 AM   #6 (permalink)
Yamaha 4 Life!
 
TheSnowPro's Avatar
 
Join Date: Mar 2009
Location: Coldwater, Ontario
Posts: 582
well i dont think i have a broken wrist pin because im not hearing any engine knocks, engine sounds great when it runs good. im thinking its either a dirty carb or something with the fuel pump. since it runs good with the choke half open.
__________________
Mine - 1989 Yamaha Phazer 485 w/ Comet 102C and boyesen power reeds. 14,356 kms.

Dads - 1997 Yamaha V-max XT 600 stock w/ polaris P-85 clutch

Brothers - on its way home soon! either a yamaha or skidoo. not sure what yet.


First ride of the 2009/2010 season - 11/12/09
09/10 km's - over 1200. pretty good for only half a seasons worth of riding.
TheSnowPro is offline   Reply With Quote
Old 12-15-2009, 01:52 PM   #7 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 32,102
Indicates clogged pilot jet.
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 12-15-2009, 07:14 PM   #8 (permalink)
Registered User
 
Join Date: Nov 2009
Posts: 12
it could all b that but mine didnt make a sound so i was cluse less...i was sure surprized when we pulled it apart and it was broke
fuzz is offline   Reply With Quote
Old 12-15-2009, 10:03 PM   #9 (permalink)
Yamaha 4 Life!
 
TheSnowPro's Avatar
 
Join Date: Mar 2009
Location: Coldwater, Ontario
Posts: 582
Quote:
Originally Posted by RJ Gleason View Post
Indicates clogged pilot jet.
me and my dad were just talking about that the other day. im not sure im up to cleaning the carbs and my dads not home very often to be able to do it for me. i heard about this "start your engines" stuff on spike last weekend and it looked pretty promising. i've used the HEET gas line anti-freeze the same company makes and it worked great when i had water in the tank.

check it out - New Start Your Engines®! Product Fuel System Revitalizer For Out of Storage and In-Season Use
__________________
Mine - 1989 Yamaha Phazer 485 w/ Comet 102C and boyesen power reeds. 14,356 kms.

Dads - 1997 Yamaha V-max XT 600 stock w/ polaris P-85 clutch

Brothers - on its way home soon! either a yamaha or skidoo. not sure what yet.


First ride of the 2009/2010 season - 11/12/09
09/10 km's - over 1200. pretty good for only half a seasons worth of riding.
TheSnowPro is offline   Reply With Quote
Old 12-16-2009, 08:28 AM   #10 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 32,102
Tech section> engine/drive train> How to's> Mikuni round slide carb cleaning link
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 12-16-2009, 11:50 AM   #11 (permalink)
Yamaha 4 Life!
 
TheSnowPro's Avatar
 
Join Date: Mar 2009
Location: Coldwater, Ontario
Posts: 582
its not that i cant take the carbs out and clean them. its just getting them back together and back in the sled. my manual has a section on cleaning the carbs. just trying to make things easier since my dads barely home to be able to do it.
__________________
Mine - 1989 Yamaha Phazer 485 w/ Comet 102C and boyesen power reeds. 14,356 kms.

Dads - 1997 Yamaha V-max XT 600 stock w/ polaris P-85 clutch

Brothers - on its way home soon! either a yamaha or skidoo. not sure what yet.


First ride of the 2009/2010 season - 11/12/09
09/10 km's - over 1200. pretty good for only half a seasons worth of riding.

Last edited by TheSnowPro; 12-16-2009 at 12:04 PM.
TheSnowPro is offline   Reply With Quote
Old 12-16-2009, 01:38 PM   #12 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 32,102
If you do them one at a time, you have the other one to refer to if needed.
Follow the instructions and you should have no trouble doing it yourself.
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 12-16-2009, 06:20 PM   #13 (permalink)
-LIFETIME MEMBER-
 
Join Date: Nov 2009
Posts: 5,009
Quote:
Originally Posted by RJ Gleason View Post
If you do them one at a time, you have the other one to refer to if needed.
Follow the instructions and you should have no trouble doing it yourself.
and take a picture or pay special attention to the location of the rubber caps on the intake side. it will really act up if you loose or install incorrectly.
yamadad4 is offline   Reply With Quote
Old 12-16-2009, 10:09 PM   #14 (permalink)
Yamaha 4 Life!
 
TheSnowPro's Avatar
 
Join Date: Mar 2009
Location: Coldwater, Ontario
Posts: 582
thanks guys, ill be taking the carbs out tomorrow and give them a cleaning. i have the service manual for my sled. im very mechanically inclined, it's just some things i've never done before that tend to intimidate me a bit. i just dont want to mess anything up. ill let you know how i make out and how it runs afterward.

Cheers!
__________________
Mine - 1989 Yamaha Phazer 485 w/ Comet 102C and boyesen power reeds. 14,356 kms.

Dads - 1997 Yamaha V-max XT 600 stock w/ polaris P-85 clutch

Brothers - on its way home soon! either a yamaha or skidoo. not sure what yet.


First ride of the 2009/2010 season - 11/12/09
09/10 km's - over 1200. pretty good for only half a seasons worth of riding.
TheSnowPro is offline   Reply With Quote
Old 12-17-2009, 12:34 PM   #15 (permalink)
Yamaha 4 Life!
 
TheSnowPro's Avatar
 
Join Date: Mar 2009
Location: Coldwater, Ontario
Posts: 582
well got the carbs pulled out and soaking in the cleaner. gunna go back out in an hour or so and blow them out with the air compressor. ill let you know how it turns out!

Cheers!
__________________
Mine - 1989 Yamaha Phazer 485 w/ Comet 102C and boyesen power reeds. 14,356 kms.

Dads - 1997 Yamaha V-max XT 600 stock w/ polaris P-85 clutch

Brothers - on its way home soon! either a yamaha or skidoo. not sure what yet.


First ride of the 2009/2010 season - 11/12/09
09/10 km's - over 1200. pretty good for only half a seasons worth of riding.
TheSnowPro is offline   Reply With Quote
Old 12-17-2009, 01:38 PM   #16 (permalink)
Yamaha 4 Life!
 
TheSnowPro's Avatar
 
Join Date: Mar 2009
Location: Coldwater, Ontario
Posts: 582
carbs are looking brand new just finished blowing them out with compressed air and now just waiting for them to dry before sticking them back in the machine. thanks for the help guys and hopefully this solves the problem!

@fuzz- when i had my sled out the other day before it started acting up i had it doing about 65mph, according to the speedo.
__________________
Mine - 1989 Yamaha Phazer 485 w/ Comet 102C and boyesen power reeds. 14,356 kms.

Dads - 1997 Yamaha V-max XT 600 stock w/ polaris P-85 clutch

Brothers - on its way home soon! either a yamaha or skidoo. not sure what yet.


First ride of the 2009/2010 season - 11/12/09
09/10 km's - over 1200. pretty good for only half a seasons worth of riding.
TheSnowPro is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:22 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0