77 ski doo 340 Olympique - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 01-16-2010, 10:16 PM Thread Starter
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
77 ski doo 340 Olympique

hello i have a 77 ski doo 340. when riding it it will make a popping sound. it is coming from the motor. it's not a backfire sound. anyone have any ideals on what it could be?
indyryder500 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 01-17-2010, 02:00 PM Thread Starter
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
????????????????
indyryder500 is offline  
post #3 of 11 (permalink) Old 01-17-2010, 11:58 PM Thread Starter
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hellooooooooooo
indyryder500 is offline  
post #4 of 11 (permalink) Old 01-18-2010, 08:21 AM
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 33,347
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Sound of crickets..



















Single cyl or twin?

Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

http://www.dcdrifters.net/

Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline  
post #5 of 11 (permalink) Old 01-18-2010, 04:34 PM
Registered User
 
Join Date: Feb 2007
Posts: 621
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Popping back in through the carb?
Put it up on a stand, can you make it happen? Make a video and send us the link...
Its hard to diagnose "a popping sound" with nothing else to go by.

Raising sleds from the dead in north central MA.
'70 Ski-Doo Olympique 12/3 - The Yellow Bullet
'71 Arctic Cat Panther 303 - Wankle Panther
'78 Arctic Cat Pantera 5000 - Back from the dead!
'79 Polaris Cobra 340 - Back from the dead!
'95 Ski-Doo Grand Touring SE 670



www.deadsledwrenchers.net
curtludwig is offline  
post #6 of 11 (permalink) Old 01-18-2010, 05:04 PM Thread Starter
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
my camera don't have sound or i just haven't figured it out yet lol. i just want it to last the rest of the year. i'm going to tear it all down this summer and restore it.
indyryder500 is offline  
post #7 of 11 (permalink) Old 01-18-2010, 05:06 PM Thread Starter
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
it sounds like the heads but i replaced the gaskets on them at the beginning of the year. becuse it made that sound last year and thats what i was thinking it was. but it didn't stop the popping sound. when it does it it like surges also.
indyryder500 is offline  
post #8 of 11 (permalink) Old 01-18-2010, 08:07 PM
Registered User
 
Join Date: Feb 2007
Posts: 621
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Does it do it if you lift the track? Can you run it like that with the hood open so you can see whats going on?

Raising sleds from the dead in north central MA.
'70 Ski-Doo Olympique 12/3 - The Yellow Bullet
'71 Arctic Cat Panther 303 - Wankle Panther
'78 Arctic Cat Pantera 5000 - Back from the dead!
'79 Polaris Cobra 340 - Back from the dead!
'95 Ski-Doo Grand Touring SE 670



www.deadsledwrenchers.net
curtludwig is offline  
post #9 of 11 (permalink) Old 01-18-2010, 09:25 PM
Registered User
 
Join Date: Jan 2010
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check your crank seals....they may be bad..
GoodolWolverine is offline  
post #10 of 11 (permalink) Old 01-19-2010, 12:40 PM
Registered User
 
Join Date: Feb 2007
Posts: 621
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
If the engine has decent power, starts easy and the plugs are tan I wouldn't worry about crank seals but its definitely a possibility.

Raising sleds from the dead in north central MA.
'70 Ski-Doo Olympique 12/3 - The Yellow Bullet
'71 Arctic Cat Panther 303 - Wankle Panther
'78 Arctic Cat Pantera 5000 - Back from the dead!
'79 Polaris Cobra 340 - Back from the dead!
'95 Ski-Doo Grand Touring SE 670



www.deadsledwrenchers.net
curtludwig is offline  
post #11 of 11 (permalink) Old 01-25-2010, 06:33 AM
Registered User
 
Join Date: Nov 2008
Location: Sarnia On
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have the same problem in a 1980 citation. It will pop and then run really good and then seem to bog down until it pops again and away it goes. I have been told that it is running to lean and that pop is preignition from gases in the cylinder igniting before they are supposed to.The spark plugs electrodes melt off when this happens so it's easy to tell that it is too hot. Some of the sugestions I have been told is crank seals or maybe carb boots.Try spraying a little starting fluid around the crank seals and carb boots and if it runs different that is where your problem lays.

1991 Formula MX
1979 Everest 444 L/C
1980 Citation 300
1976- 340 oly
1972-299 Oly
1992 570 Yamaha Exciter II
formulamx91 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome