77 ski doo 340 Olympique - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Vintage Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 01-16-2010, 10:16 PM   #1 (permalink)
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
77 ski doo 340 Olympique

hello i have a 77 ski doo 340. when riding it it will make a popping sound. it is coming from the motor. it's not a backfire sound. anyone have any ideals on what it could be?
indyryder500 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-17-2010, 02:00 PM   #2 (permalink)
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
????????????????
indyryder500 is offline   Reply With Quote
Old 01-17-2010, 11:58 PM   #3 (permalink)
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
hellooooooooooo
indyryder500 is offline   Reply With Quote
Old 01-18-2010, 08:21 AM   #4 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 32,285
Sound of crickets..



















Single cyl or twin?
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 01-18-2010, 04:34 PM   #5 (permalink)
Registered User
 
Join Date: Feb 2007
Posts: 621
Popping back in through the carb?
Put it up on a stand, can you make it happen? Make a video and send us the link...
Its hard to diagnose "a popping sound" with nothing else to go by.
__________________
Raising sleds from the dead in north central MA.
'70 Ski-Doo Olympique 12/3 - The Yellow Bullet
'71 Arctic Cat Panther 303 - Wankle Panther
'78 Arctic Cat Pantera 5000 - Back from the dead!
'79 Polaris Cobra 340 - Back from the dead!
'95 Ski-Doo Grand Touring SE 670



www.deadsledwrenchers.net
curtludwig is offline   Reply With Quote
Old 01-18-2010, 05:04 PM   #6 (permalink)
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
my camera don't have sound or i just haven't figured it out yet lol. i just want it to last the rest of the year. i'm going to tear it all down this summer and restore it.
indyryder500 is offline   Reply With Quote
Old 01-18-2010, 05:06 PM   #7 (permalink)
Rick
 
indyryder500's Avatar
 
Join Date: Jan 2010
Location: Upper Michigan
Posts: 3,070
it sounds like the heads but i replaced the gaskets on them at the beginning of the year. becuse it made that sound last year and thats what i was thinking it was. but it didn't stop the popping sound. when it does it it like surges also.
indyryder500 is offline   Reply With Quote
Old 01-18-2010, 08:07 PM   #8 (permalink)
Registered User
 
Join Date: Feb 2007
Posts: 621
Does it do it if you lift the track? Can you run it like that with the hood open so you can see whats going on?
__________________
Raising sleds from the dead in north central MA.
'70 Ski-Doo Olympique 12/3 - The Yellow Bullet
'71 Arctic Cat Panther 303 - Wankle Panther
'78 Arctic Cat Pantera 5000 - Back from the dead!
'79 Polaris Cobra 340 - Back from the dead!
'95 Ski-Doo Grand Touring SE 670



www.deadsledwrenchers.net
curtludwig is offline   Reply With Quote
Old 01-18-2010, 09:25 PM   #9 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 20
Check your crank seals....they may be bad..
GoodolWolverine is offline   Reply With Quote
Old 01-19-2010, 12:40 PM   #10 (permalink)
Registered User
 
Join Date: Feb 2007
Posts: 621
If the engine has decent power, starts easy and the plugs are tan I wouldn't worry about crank seals but its definitely a possibility.
__________________
Raising sleds from the dead in north central MA.
'70 Ski-Doo Olympique 12/3 - The Yellow Bullet
'71 Arctic Cat Panther 303 - Wankle Panther
'78 Arctic Cat Pantera 5000 - Back from the dead!
'79 Polaris Cobra 340 - Back from the dead!
'95 Ski-Doo Grand Touring SE 670



www.deadsledwrenchers.net
curtludwig is offline   Reply With Quote
Old 01-25-2010, 06:33 AM   #11 (permalink)
Registered User
 
Join Date: Nov 2008
Location: Sarnia On
Posts: 31
I have the same problem in a 1980 citation. It will pop and then run really good and then seem to bog down until it pops again and away it goes. I have been told that it is running to lean and that pop is preignition from gases in the cylinder igniting before they are supposed to.The spark plugs electrodes melt off when this happens so it's easy to tell that it is too hot. Some of the sugestions I have been told is crank seals or maybe carb boots.Try spraying a little starting fluid around the crank seals and carb boots and if it runs different that is where your problem lays.
__________________
1991 Formula MX
1979 Everest 444 L/C
1980 Citation 300
1976- 340 oly
1972-299 Oly
1992 570 Yamaha Exciter II
formulamx91 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:59 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0