95 formula sl 500 fan - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Ski-Doo Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 01-14-2013, 08:36 AM   #1 (permalink)
Registered User
 
Join Date: Jan 2013
Location: Lloydminster Canada
Posts: 2
Thumbs up 95 formula sl 500 fan

Guy I have a 95 formula sl fan runs awesome. The other day it was -36 so I put some gas line anti freeze in the feul. Fouled a plug replace plug and ran fin for a day. Know at low rpm it floods the pto side cylinder and boots down. But as soon as I get me rpm up it runs off both cylinders. Tried everything I can get it to run good at idle but onLy if I remove that side throttle plug from the carb. Then it idles like it should.can anyone explain why and give me some ideas to fix it. Maybe the plug is not seating propErly but why does it run when fuly removed.

Thanks guys
Vandals44 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-14-2013, 11:23 AM   #2 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 31,856
Primer or chokes on that engine?
Also look and see if there is any fuel in the pump pules line [connects fuel pump to base of engine on the clutch side cylinder], you might have a pump in need of a rebuild.
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 01-14-2013, 11:37 AM   #3 (permalink)
Registered User
 
Join Date: Jan 2013
Location: Lloydminster Canada
Posts: 2
This engine has chokes. It's getting lots of feul. To much I think. I think we it's running better when I remove hat choke plug is that it's getting more air. Would that choke plug be not sealing properly
Vandals44 is offline   Reply With Quote
Old 01-15-2013, 06:17 AM   #4 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,643
Remove and clean that carb, then adjust the choke.
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo Grand Touring
1998 Ski Doo Grand Touring
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:41 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0