96 formula 3 backfiring - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-28-2012, 11:47 AM Thread Starter
Registered User
 
codyccg's Avatar
 
Join Date: Nov 2012
Location: michigan
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
96 formula 3 backfiring

yesterday my sled was running just perfect. now it backfires and doesnt run as well. whats causing this? thanks
codyccg is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-28-2012, 01:07 PM
Registered User
 
DitchPklCowboy's Avatar
 
Join Date: Feb 2012
Location: Independence mn
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
When mine started this it was a wrist pin going bad in the middle cylinder. 4000+ miles


Sent from my iPhone using Snowmobile.com App
DitchPklCowboy is offline  
post #3 of 3 (permalink) Old 12-29-2012, 06:55 AM
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,798
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Plug starting to foul out on it. Take all 3 out and have a look. One will probably be wet and oily looking.

1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo MXZ600
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome