96 formula 3 backfiring - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Ski-Doo Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-28-2012, 11:47 AM   #1 (permalink)
Registered User
 
codyccg's Avatar
 
Join Date: Nov 2012
Location: michigan
Posts: 10
96 formula 3 backfiring

yesterday my sled was running just perfect. now it backfires and doesnt run as well. whats causing this? thanks
codyccg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-28-2012, 01:07 PM   #2 (permalink)
Registered User
 
DitchPklCowboy's Avatar
 
Join Date: Feb 2012
Location: Independence mn
Posts: 25
When mine started this it was a wrist pin going bad in the middle cylinder. 4000+ miles


Sent from my iPhone using Snowmobile.com App
DitchPklCowboy is offline   Reply With Quote
Old 12-29-2012, 06:55 AM   #3 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,642
Plug starting to foul out on it. Take all 3 out and have a look. One will probably be wet and oily looking.
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo Grand Touring
1998 Ski Doo Grand Touring
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:59 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0