95 Summit 670 won't run - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Ski-Doo Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-26-2012, 02:40 PM   #1 (permalink)
Registered User
 
Join Date: Dec 2012
Location: North Central WA
Posts: 3
Question 95 Summit 670 won't run

Hello,

I'm new to this forum. I would appreciate some help with a 95 summit 670 I am working on. Hopefully some of you have had similar probs.

Symptoms: was flooding crankcase, will run for a couple seconds then die, water in fuel.

repairs so far: new fuel pump, cleaned carbs and needle jets, checked bowl height, gas dryer in fuel.

I can get it to run with starting fluid for a few seconds, then it dies. Any feedback would be appreciated.
CJ Cycle is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-26-2012, 02:45 PM   #2 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 144
You could siphon out all of the gas or drain the gas. Then, put fresh gas in.
freaknyea is offline   Reply With Quote
Old 12-26-2012, 03:16 PM   #3 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 144
I don't know what the gas dryer is that you are referring to, but when you say water in gas... the first thing that comes to mind is put in new gas. I have had water in my motorcycle gas tank before. They bike would idle all day, but if I hit the throttle it would immediately cut out. If you have water in your tank your sled isn't going anywhere.
freaknyea is offline   Reply With Quote
Old 12-26-2012, 04:13 PM   #4 (permalink)
Registered User
 
Join Date: Dec 2012
Location: North Central WA
Posts: 3
I siphoned all the gas out. I am going to try that. Thanks for the help.

I put the mikuni fuel pump on it. I am just wondering if it is too small and not getting enough gas? I is the square pump with 2 outlets, 1 inlet and 1 suction.
CJ Cycle is offline   Reply With Quote
Old 12-26-2012, 04:29 PM   #5 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 144
Unfortunately, I'm not familiar with the sled, so wouldn't know what to tell you in that regard. Maybe someone else can offer a little more information specifically to that. What kind of carb/pump should it have in it?
freaknyea is offline   Reply With Quote
Old 12-26-2012, 07:06 PM   #6 (permalink)
Registered User
 
mikem's Avatar
 
Join Date: Jan 2012
Location: Port Elgin On. Canada
Posts: 37
If you replaced your fuel pump, you would have replaced it with the same size and style. Dual carb requires 2 outlets and a triple needs 3 outlets. Sounds to me you have the right one. Did you check your floats in the bowl? There is a high flow pump(65 litres/hr) and regular flow(31litres/hr). You can try googleing the specs for your sled or call a skidoo dealer. Sometimes priming the system will helpget the fuel flowing. Also check that your lines are running to the right location.
mikem is offline   Reply With Quote
Old 12-26-2012, 07:07 PM   #7 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,701
The pump should be OK. Drain the carb bowls and try again.
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo MXZ600
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Old 12-26-2012, 07:12 PM   #8 (permalink)
Registered User
 
Join Date: Dec 2012
Location: North Central WA
Posts: 3
Got it runnin, ran it around the place a few times. Shut it down and now I can't even get a hint of fire even with starting fluid. Checked spark and have that. Any other suggestions?
CJ Cycle is offline   Reply With Quote
Old 12-27-2012, 05:51 PM   #9 (permalink)
bilbobagginz
 
Join Date: Jul 2011
Location: central ny, munnsville
Posts: 40
try new plugs. i would have 2-3 sets.
bilbobagginz is offline   Reply With Quote
Old 12-28-2012, 07:53 AM   #10 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,701
Have you drained all the old fuel out? Are you draining the bowls?
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo MXZ600
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:23 PM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0