Electronic Gauge - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Ski-Doo Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 11-05-2012, 08:58 AM   #1 (permalink)
Registered User
 
ArcticCanon's Avatar
 
Join Date: Oct 2012
Location: Canada
Posts: 13
Electronic Gauge

I have a 2009 model MXZ 500 TNT. I have been running it for about 4 years now and the electronic fuel gauge started acting up last season. It'll say it's on empty even when it has a full tank of gas. Started up my machine more than a week ago and bought gas when I forgot the gauge is not always accurate, so I had 14L left over when I thought it was on empty. Has anyone dealt with this problem before?
ArcticCanon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-06-2012, 03:51 AM   #2 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,687
I think it's a common issue with the sending unit in the tank.
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo Grand Touring
1998 Ski Doo Grand Touring
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:29 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0