1997 Ski-doo Mach Z 800 {RUNNING PROBLEMS} - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 12-27-2010, 12:48 PM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
1997 Ski-doo Mach Z 800 {RUNNING PROBLEMS}

Can't seem to figure out why my sled will run like a rocket for a mile or so then completly stop running.Wait a minute or two and she'll go again like a rocket another mile then samething.Gonna be a long winter if she keeps this up,put it up on blocks and she'll run hard for several minutes,put er back on the ground and go amile and stop....WHAT THE HELLS WRONG????

Now it won't start AT ALL
Mach Z 800 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 12-27-2010, 12:51 PM
Registered User
 
BskidooC's Avatar
 
Join Date: Dec 2005
Location: Laramie WY
Posts: 996
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
3 things you need to check for
1. Fuel/air
2.spark(I think spark may be your problem)
3. Compression

Check these 3 things and get back to us with as much information as possible, the more you can get the easier it will be for us to help.

when hell freezes over ill ride there to
BskidooC is offline  
post #3 of 16 (permalink) Old 12-27-2010, 12:57 PM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Again thanks BskiddoC........I'll check this out soon as I get some help,hard to check for spark alone.
Mach Z 800 is offline  
post #4 of 16 (permalink) Old 12-27-2010, 12:59 PM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Fuel/air and compression all seem to be fine this morning,although from time to time there's not alot of fuel going through the line.But always some
Mach Z 800 is offline  
post #5 of 16 (permalink) Old 12-27-2010, 05:10 PM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Just had it running in the dark and theres no arcing coming from anywhere.It ran about 3 minutes and stopped.I never tried to restart it again.
Mach Z 800 is offline  
post #6 of 16 (permalink) Old 12-27-2010, 05:13 PM
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 33,347
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
New fuel filter in it?
Check that something is not covering the pick up screen in the tank too.

Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

http://www.dcdrifters.net/

Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline  
post #7 of 16 (permalink) Old 12-27-2010, 05:19 PM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RJ....The only filter on this sled is in the tank,I had problems last week with that,so you could be onto something here.I noticed alot of rust {from the gas gauge} in the bottom of the tank so that could be clogging the filter.
Mach Z 800 is offline  
post #8 of 16 (permalink) Old 12-27-2010, 05:29 PM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Last week......my fuel line inside the tank came off.I drained the tank and replaced the line and filter.I did however notice a large ammount of rust and crap laying on the bottom of the tank now...is it possible that this crap is clogging my filter and if so is there an easy way to find this out without taking it all apart again?
Mach Z 800 is offline  
post #9 of 16 (permalink) Old 12-27-2010, 05:35 PM
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 33,347
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Drain it as much as you can. Use a rag on a stiff wire and wipe as much as you can out.

Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

http://www.dcdrifters.net/

Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline  
post #10 of 16 (permalink) Old 12-27-2010, 05:40 PM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My rust and crap is coming from the gas gauge unit itself,how am I gonna get clear of this without replacing the unit?And thanks for your help btw.
Mach Z 800 is offline  
post #11 of 16 (permalink) Old 12-27-2010, 05:40 PM
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 33,347
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Rust remover (petroleum jelly).

Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

http://www.dcdrifters.net/

Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline  
post #12 of 16 (permalink) Old 12-28-2010, 11:18 AM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Lastnight when it stopped running the gasline that goes down to the pump was empty,now after sitting all night is 100% full.Does that sound like my problem is within the tank itself?
I'm now in the process of draining the tank and will be cleaning the crap outta it and trying it again.Hopefully this will be it!!
Mach Z 800 is offline  
post #13 of 16 (permalink) Old 12-28-2010, 04:30 PM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Drained the tank,cleaned all the crap outta ther {shop vac} and put it back togeather.Ran great for longer than usual this time but again,bogged down.Didn't completly stop but pretty much.Lights and everything got real dim.
Mach Z 800 is offline  
post #14 of 16 (permalink) Old 12-28-2010, 04:32 PM Thread Starter
Registered User
 
Mach Z 800's Avatar
 
Join Date: Oct 2010
Location: Nova Scotia,Canada
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
she started acting up about the time she got to running temp to BTW
Mach Z 800 is offline  
post #15 of 16 (permalink) Old 01-08-2013, 09:13 AM
Registered User
 
Join Date: Jan 2013
Location: Williamsport pa
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Did you fighre out whag your problem Was?

Hey, I have the same exact sled as you and it's ironic because I am experiencing the same exact problem you were. It starts up and runs for three mins and then dies and it does this a few times and then won't start at all. Was wondering if you found out what it was? Thanks in advanced
Andyrish is offline  
post #16 of 16 (permalink) Old 01-09-2013, 05:52 AM
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,804
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My money is on the stator going out on it. Check for spark immediately after it quits. They were famous for it..

1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo MXZ600
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome