MXZ 470 Problem - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-10-2010, 09:07 PM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
MXZ 470 Problem

Hello I have a problem maybe someone can help me with

1994 mxz 470
rebuilt motor 200 miles ago

ran great and then it just lacked power and would bog out

I put new plugs in and gaped them . The muffler was a bit loose so i tighted that up

it has 150 PSI in one piston and 143 in the other

I think the carbs need to be tuned I did pull them apart and cleaned them I did not touch the air screw and idle untill i put them back on then I tuned them clockways 1/2 turn and it runs better .

It runs great and start up then like 1/2 mile down the road it will spit and spudder and you have to play with the gas to get it to go . I was thinking that the auto oiler was bad so i mixed it in the tank .. and now i hooked the auto oiler back up . I do not want to blow the motor . The plugs are not oily looking . I would call them and tanish color like a paper bag burning . Also i checked all the seals with eather to see if I have a air leak .. Can somone help
chadmilliser is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-10-2010, 10:13 PM
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,759
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Your fuel pump may need a rebuild.

1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo MXZ600
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline  
post #3 of 5 (permalink) Old 01-10-2010, 10:14 PM
Registered User
 
Dbl R's Avatar
 
Join Date: Feb 2009
Location: Belding, MI
Posts: 350
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Check Cluthes/Belt, sticky brake ... Sounds to be running good with those plug colors. check throttle cable adjustment also!
Dbl R is offline  
post #4 of 5 (permalink) Old 01-10-2010, 10:40 PM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thanks

I was thinking fuel pump !!! I have a few around tomarrow i will buy pass the old one and try another one .
chadmilliser is offline  
post #5 of 5 (permalink) Old 01-13-2010, 01:27 AM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
crank bearing

hello there I found out what was messing it up . the crank bearing on the pto side . If you look down by the cluch you can see a spot as thin as a penny that is shinny metal . like the cluch slid! and if you spray ether on it for a bit it will slowly rev !!! so i got the motor all tore down and a good crank shaft and seals on there way . Im taking it to a shop to pull my cluch and stator and then have them retime it . they told me 20.00 $$$$ to do all this ! is timing of this think hard I know it will be hard to get the new crankshaft in the same spot as the old . is there any good way to time a rotax 470 !! MY old bottom end had 200 miles on it and it is clean as can be !!! and i have to replace it .
chadmilliser is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome