no spark on 04 summit rev 800 - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Ski-Doo Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 05-04-2009, 01:47 AM   #1 (permalink)
Registered User
 
Join Date: Oct 2008
Location: Fairbanks, AK
Posts: 18
no spark on 04 summit rev 800

i have an 04 summit 800 rev.
i was goin to load it in to the back of my truck so i had it idleing and when i walked away it just died. it was like you just pulled the DESS cord off of it.
i try to start it but it has no spark
im thinking that my DESS cord just took a sh*t on me. is this a common problem?
is there a way i can test it on my own to see if that is whts wrong?
my local Ski-Doo dealer wants $180 jus to see if thats whats wrong and i cant see payin them that.
is there anything else that could cause it to not have spark too?
any help would be great
and if any info needed please let me kno
__________________
::New sled::
2004 summit 800
144, fly bars an risers, mbrp can, and custom dark red marblized paint
more add ons an changes to come

::Past sled::
2000 RMK 700
flat black paint, fox floats up front, rear drop bracket, 4inch powermadd block riser, powermadd pivot riser
Gunner00rmk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-04-2009, 06:38 AM   #2 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,687
Find another dealer if you can. That's WAY too much to do that.
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo Grand Touring
1998 Ski Doo Grand Touring
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Old 05-09-2009, 12:32 AM   #3 (permalink)
Registered User
 
BskidooC's Avatar
 
Join Date: Dec 2005
Location: Laramie WY
Posts: 996
Even if the key did take a crap u would still have spark, engine will govern out at 3500 rpm. The problem could be a number of things, maybe a bad kill switch, bad DESS post, module, mag, voltage regulator...Could be a ton of things, find a dealer worth going to.
__________________
when hell freezes over ill ride there to
BskidooC is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:15 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0