1993 Mxz 470 won't idle - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-02-2008, 09:23 PM Thread Starter
Registered User
 
Join Date: Feb 2008
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
1993 Mxz 470 won't idle

Fresh gas and plugs was the first thing done to fix an idle issue. I have dismantled, cleaned, and checked the settings on the carbs of this 1993 MXZ 470. The air mixture is set back 1.5 turns from seated as per specs. The fuel filter has been replaced. It runs smooth over 2500rpm but below this is eventually stalls unless you bring the rpms back up. The spec idle is 1500-1700rpm.
Is this an indication of a fuel pump problem??

Last edited by Pete C.; 02-02-2008 at 09:25 PM. Reason: Better title
Pete C. is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-03-2008, 04:09 AM
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 33,347
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
No, likely the idle circuit is still partially clogged.
Clean the carbs by using the soak method and chase the jet with a piece of wire or mono-filament fish line to ensure that they are clear and blow them out with compressed air.

Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

http://www.dcdrifters.net/

Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline  
post #3 of 6 (permalink) Old 02-05-2008, 03:26 PM
Registered User
 
iceman400's Avatar
 
Join Date: Jul 2007
Location: keswick, ontario, canada
Posts: 480
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have the same problem.. i got a 93 formula plus and it runs great when your moving but it idles real low and will stall after about 40 secconds if you don't keep it going.. it will fire right back up after it stalls.... so clean the carbs?i have never cleaned them before but i have never had the need to it always ran great up till last year thats when it started to idle low.

Connor.

2001 Machz 800 spring order yellow
1998 ski-doo mxz 440
1998 Jeep grand cherokee 5.9
1966 Dodge Charger-BAD ASS
iceman400 is offline  
post #4 of 6 (permalink) Old 02-05-2008, 04:11 PM
GO GREEN OR GO HOME!
 
SkiDooFormulaMX's Avatar
 
Join Date: Feb 2006
Location: Schenectady, NY
Posts: 1,564
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
buddies sled did this and it was a cracked and leaking carb boot

2004 F7 SNO PRO 3853 MILES, ODS CLUTCHING, GEARED, BMP PIPE, D&D Y PIPE, SLP INTAKE
2003 F5 STANDARD 2201 MILES
2002 Z440 ES 2650 MILES
SkiDooFormulaMX is offline  
post #5 of 6 (permalink) Old 02-05-2008, 05:44 PM
Registered User
 
iceman400's Avatar
 
Join Date: Jul 2007
Location: keswick, ontario, canada
Posts: 480
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
carb boots are fine... no leaks they look brand new.. i think i just gotta clean em and just set the idle.

2001 Machz 800 spring order yellow
1998 ski-doo mxz 440
1998 Jeep grand cherokee 5.9
1966 Dodge Charger-BAD ASS
iceman400 is offline  
post #6 of 6 (permalink) Old 02-05-2008, 07:55 PM Thread Starter
Registered User
 
Join Date: Feb 2008
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
All, I found the problem and the sled now idles without stalling. Here's how! Inside the VM34 Mikuni carbs is the pilot jet (supplies gas at idle), needle/ needle jet (supplies gas at midrange), and main jets (full throttle). The pilot jet is easily unscrewed with a flathead screwdriver. It has an opening as small as a needle with 6 additional openings on its body. Remove the float bowl and inside one of the crevices is the brass pilot jet. I simply used a needle to poke all the holes and used compressed air to blow all the junk out. After this you may as well clean your main jets as well. Unscrew the top of the carb to pull out the slide and blow out the needle jet as well. Finally, I used a small punch to remove the pin that holds some other small jet?? Be careful removing the retainer ring, and pull out the spring loaded mechanism to reveal another orifice.
Reassemble and set the air mixture as per spec, in my case it was 1.5 turns back from seated. I also used a marker on the idle screws which I backed out 2 full truns from seated. The sled fired immediately, and idled at 1600rpm with no further problems. Hope this helps. Pete
Pete C. is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome