Pull Start Frozen up - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Ski-Doo Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 10-18-2007, 02:33 PM   #1 (permalink)
Registered User
 
Join Date: Oct 2007
Location: Toronto
Posts: 4
Pull Start Frozen up

On my used 2004 Legend 8000 Sdi the electric start works fine but the pull start wont engage the engine. The recoil works fine. How do I free it up, where do I start ?? Thanks Derek
Derek Harrison is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2007, 02:53 PM   #2 (permalink)
King of the Universe
 
IndianRvrShiver's Avatar
 
Join Date: Jan 2005
Location: Rochester Hizzle, MI
Posts: 6,678
Remove the entire recoil assembly, then look to see if the engagement pawl is extending when you pull the rope. As long as you don't let the spring get away from you, they're pretty simple to work on.
__________________
********************
2003 AC F5 (Jr's Dec 07 SOTM & 2008 SOTY)
2003 AC F7 EFI SP (April 06 SOTM)
********************


"It's a public access forum, you post stupidity, expect to get flamed." - RJ Gleason
IndianRvrShiver is offline   Reply With Quote
Old 11-07-2007, 04:52 PM   #3 (permalink)
sundaypuncher 503
 
skidoo kid 102's Avatar
 
Join Date: Jun 2006
Location: maine
Posts: 289
you might of got water in there (depending on how cold it was) and it froze up? o had that happen to my mxz 380, so i put some oil/wd40 on the pull rope to displace the water. worked for me?
__________________
THE BEST THINGS IN LIFE GO BRAAAAAP!!!!!!
skidoo kid 102 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:56 PM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0