98 summit x 670, and brand new here lol - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Ski-Doo Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 11-08-2006, 01:51 PM   #1 (permalink)
Dazed and Confused
 
Join Date: Nov 2006
Location: Grande Prairie Alberta
Posts: 5
98 summit x 670, and brand new here lol

Hi all glad to have found this site, hoping maybe someone can point me in the right direction.Bought the boy a 98 670 summit x 2 years ago, ran fine always, 2000km on it. Finally got some snow here, but for some reason have a real lack of power happening,new plugs, stored with lots of stabilized fuel over the summer fires right up and idles great lots of snap in the bottom, but just doesnt wanna go in the powder at all, top speed of 40. really sluggish. plugs appear to be burning clean with no fouling at all. this thing has the dpm rave system on it which i know nothing about, is that/or should it be adjustable or can that system screw up, cause it almost seems like a jetting problem to me. cleaned and lubed the clutch before use as well and all seems fine in there (all stock). Local dealer cant touch it for minimum 2 weeks and the kid wants to go to the mountains this weekend lol. anybody have any ideas where to start with this. any help would be appreciated. Also kid wants a can for his b-day for it to spruce it up a bit, any ideas on whats a good one for this thing?
Tab33 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-08-2006, 07:56 PM   #2 (permalink)
Dazed and Confused
 
Join Date: Nov 2006
Location: Grande Prairie Alberta
Posts: 5
Anybody......?
Tab33 is offline   Reply With Quote
Old 11-09-2006, 05:16 AM   #3 (permalink)
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,682
3 things can do that: Carb jets, clutch is AFU (sounds like you checked that) or the RAVES aren't opening.
__________________
1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo Grand Touring
1998 Ski Doo Grand Touring
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline   Reply With Quote
Old 11-11-2006, 08:50 PM   #4 (permalink)
Addicted to Snow
 
[tHe] Saint's Avatar
 
Join Date: Nov 2006
Location: Spokane
Posts: 82
^^^^

what he said about the raves
__________________
2000 Summit Highmark
1995 Summit 583

[tHe] Saint is offline   Reply With Quote
Old 11-12-2006, 11:55 PM   #5 (permalink)
Dazed and Confused
 
Join Date: Nov 2006
Location: Grande Prairie Alberta
Posts: 5
thanks for the input guys, next questons is are the raves servicable or do ya replace them, also, how do you set them up? they dont seem to be turned in the same amount on both cylinders. thanks all
Tab33 is offline   Reply With Quote
Old 11-13-2006, 11:31 PM   #6 (permalink)
Addicted to Snow
 
[tHe] Saint's Avatar
 
Join Date: Nov 2006
Location: Spokane
Posts: 82
pretty much they are probably just all gummed up and not opening, they probably just need to be cleaned.
__________________
2000 Summit Highmark
1995 Summit 583

[tHe] Saint is offline   Reply With Quote
Old 11-14-2006, 11:54 AM   #7 (permalink)
sundaypuncher 503
 
skidoo kid 102's Avatar
 
Join Date: Jun 2006
Location: maine
Posts: 289
the rave valve can be taken off and cleaned. it should be pretty easy to take apart the valves. ask a dealer if he has directions on how to take them apart?
__________________
THE BEST THINGS IN LIFE GO BRAAAAAP!!!!!!
skidoo kid 102 is offline   Reply With Quote
Old 11-14-2006, 11:55 AM   #8 (permalink)
sundaypuncher 503
 
skidoo kid 102's Avatar
 
Join Date: Jun 2006
Location: maine
Posts: 289
Quote:
Originally Posted by Tab33
Hi all glad to have found this site, hoping maybe someone can point me in the right direction.Bought the boy a 98 670 summit x 2 years ago, ran fine always, 2000km on it. Finally got some snow here, but for some reason have a real lack of power happening,new plugs, stored with lots of stabilized fuel over the summer fires right up and idles great lots of snap in the bottom, but just doesnt wanna go in the powder at all, top speed of 40. really sluggish. plugs appear to be burning clean with no fouling at all. this thing has the dpm rave system on it which i know nothing about, is that/or should it be adjustable or can that system screw up, cause it almost seems like a jetting problem to me. cleaned and lubed the clutch before use as well and all seems fine in there (all stock). Local dealer cant touch it for minimum 2 weeks and the kid wants to go to the mountains this weekend lol. anybody have any ideas where to start with this. any help would be appreciated. Also kid wants a can for his b-day for it to spruce it up a bit, any ideas on whats a good one for this thing?
check out dynoport.com for a can. i think i saw one for a summit x 670 a couple of days ago?
__________________
THE BEST THINGS IN LIFE GO BRAAAAAP!!!!!!
skidoo kid 102 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:36 PM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0