98 summit x 670, and brand new here lol - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-08-2006, 01:51 PM Thread Starter
Dazed and Confused
 
Join Date: Nov 2006
Location: Grande Prairie Alberta
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
98 summit x 670, and brand new here lol

Hi all glad to have found this site, hoping maybe someone can point me in the right direction.Bought the boy a 98 670 summit x 2 years ago, ran fine always, 2000km on it. Finally got some snow here, but for some reason have a real lack of power happening,new plugs, stored with lots of stabilized fuel over the summer fires right up and idles great lots of snap in the bottom, but just doesnt wanna go in the powder at all, top speed of 40. really sluggish. plugs appear to be burning clean with no fouling at all. this thing has the dpm rave system on it which i know nothing about, is that/or should it be adjustable or can that system screw up, cause it almost seems like a jetting problem to me. cleaned and lubed the clutch before use as well and all seems fine in there (all stock). Local dealer cant touch it for minimum 2 weeks and the kid wants to go to the mountains this weekend lol. anybody have any ideas where to start with this. any help would be appreciated. Also kid wants a can for his b-day for it to spruce it up a bit, any ideas on whats a good one for this thing?
Tab33 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-08-2006, 07:56 PM Thread Starter
Dazed and Confused
 
Join Date: Nov 2006
Location: Grande Prairie Alberta
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Anybody......?
Tab33 is offline  
post #3 of 8 (permalink) Old 11-09-2006, 05:16 AM
I am Spartacus
 
smallengineguy's Avatar
 
Join Date: Feb 2004
Location: Milton Mills, NH
Posts: 23,799
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
3 things can do that: Carb jets, clutch is AFU (sounds like you checked that) or the RAVES aren't opening.

1992 Ski Doo Mach 1 (SC-10/2 suspended) March '07 SF.com Sled of the Month! (Lost in fire 4-7-13)
1992 Ski Doo Mach 1 original
2006 Ski Doo MXZ 500SS
1999 Ski Doo MXZ600
Webmaster Evergreen Valley Snowmobile Club
SledNH.com Moderator
smallengineguy is offline  
post #4 of 8 (permalink) Old 11-11-2006, 08:50 PM
Addicted to Snow
 
[tHe] Saint's Avatar
 
Join Date: Nov 2006
Location: Spokane
Posts: 82
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
^^^^

what he said about the raves

2000 Summit Highmark
1995 Summit 583

[tHe] Saint is offline  
post #5 of 8 (permalink) Old 11-12-2006, 11:55 PM Thread Starter
Dazed and Confused
 
Join Date: Nov 2006
Location: Grande Prairie Alberta
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thanks for the input guys, next questons is are the raves servicable or do ya replace them, also, how do you set them up? they dont seem to be turned in the same amount on both cylinders. thanks all
Tab33 is offline  
post #6 of 8 (permalink) Old 11-13-2006, 11:31 PM
Addicted to Snow
 
[tHe] Saint's Avatar
 
Join Date: Nov 2006
Location: Spokane
Posts: 82
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pretty much they are probably just all gummed up and not opening, they probably just need to be cleaned.

2000 Summit Highmark
1995 Summit 583

[tHe] Saint is offline  
post #7 of 8 (permalink) Old 11-14-2006, 11:54 AM
sundaypuncher 503
 
skidoo kid 102's Avatar
 
Join Date: Jun 2006
Location: maine
Posts: 289
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
the rave valve can be taken off and cleaned. it should be pretty easy to take apart the valves. ask a dealer if he has directions on how to take them apart?

THE BEST THINGS IN LIFE GO BRAAAAAP!!!!!!
skidoo kid 102 is offline  
post #8 of 8 (permalink) Old 11-14-2006, 11:55 AM
sundaypuncher 503
 
skidoo kid 102's Avatar
 
Join Date: Jun 2006
Location: maine
Posts: 289
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Tab33
Hi all glad to have found this site, hoping maybe someone can point me in the right direction.Bought the boy a 98 670 summit x 2 years ago, ran fine always, 2000km on it. Finally got some snow here, but for some reason have a real lack of power happening,new plugs, stored with lots of stabilized fuel over the summer fires right up and idles great lots of snap in the bottom, but just doesnt wanna go in the powder at all, top speed of 40. really sluggish. plugs appear to be burning clean with no fouling at all. this thing has the dpm rave system on it which i know nothing about, is that/or should it be adjustable or can that system screw up, cause it almost seems like a jetting problem to me. cleaned and lubed the clutch before use as well and all seems fine in there (all stock). Local dealer cant touch it for minimum 2 weeks and the kid wants to go to the mountains this weekend lol. anybody have any ideas where to start with this. any help would be appreciated. Also kid wants a can for his b-day for it to spruce it up a bit, any ideas on whats a good one for this thing?
check out dynoport.com for a can. i think i saw one for a summit x 670 a couple of days ago?

THE BEST THINGS IN LIFE GO BRAAAAAP!!!!!!
skidoo kid 102 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome