blowin orings - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-17-2013, 11:17 AM Thread Starter
Registered User
 
mbridgs2's Avatar
 
Join Date: Oct 2010
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
blowin orings

i have a 03 pro x 800 and the top end was just redone but i road it 5 miles and it started smoking and found out that it was burning antifreeze so i had a new thermostat and orings installed and went to ride the other day and the same thing happened to the same cylinder. i did a compression check and that side had almost 200 psi so whats going on?

If you cant fix it with a hammer then you've got an electrical problem
mbridgs2 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-17-2013, 02:24 PM
Super Moderator
 
BC_Dan's Avatar
 
Join Date: Jan 2004
Location: oregon
Posts: 13,388
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Wow, that's very high compression. Is this a normal 800? Or did they modify the combustion chamber to use race fuel in the ProX?

It's likely the 0-ring system isn't capable of handling 200 psi. Was a smaller base gasket used? Was the head shaved? How much carbon build-up is on the piston crown? Stock compression in my previous big block 800's was around 150 after a top end.

What's the compression on the other side?

2007 Dragon RMK 700 155", 2008 RMK 600 155", 95 Prowler 550 2-up, Really OLD AC Cheetah

http://www.avalanche.org/accidents.php
BC_Dan is offline  
post #3 of 3 (permalink) Old 01-17-2013, 07:06 PM Thread Starter
Registered User
 
mbridgs2's Avatar
 
Join Date: Oct 2010
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The other side is 150 that's why it's so weird. Also when I was riding it blew out the nut that was in the y-pipe and the only mods I know of are slp pipe can and air box. It has new jugs and pistons so what I'm wondering is how much is going to fix this gona cost and what could it possibly be? I just bought this sled for 2500 with a long track c&a skis. The guy is giving me an option to get my money back but the sled is everything I want so should I try and get some money back and fix it myself or take the money and find something else? Thanks for the help
Mason

If you cant fix it with a hammer then you've got an electrical problem
mbridgs2 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome