Thumb Warmer dead - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-10-2013, 07:25 AM Thread Starter
Registered User
 
Join Date: Oct 2007
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thumb Warmer dead

The thumb heater on my 2004 700 Edge Classic does not heat on any setting. Is there a fuse anywhere that i can check? OR is it most likely that the heating element in the throttle lever is just dead?

/Jimboat
2004 700 Edge Touring
Jimboat is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-10-2013, 09:29 AM
Registered User
 
meburdick's Avatar
 
Join Date: Dec 2011
Location: Northern Central CT
Posts: 2,053
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
I don't believe there are any fuses in the system. Check for a bad ground, and check to see if voltage is getting to the switch / warmer. Then, check to see if voltage is getting through the switch / warmer.

2012 Rush 600 Pro-R: https://plus.google.com/photos/11364...CObw59TN6NWvJg
1998 Indy 440: https://plus.google.com/photos/11364...10516040672513

Thank You to all of the members of the US Armed Forces
meburdick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome