03 pro x 600 - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Polaris Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-25-2012, 02:07 AM   #1 (permalink)
Registered User
 
Join Date: Dec 2012
Location: Alaska
Posts: 2
03 pro x 600

I just bought a pro x 600 with 2000 something miles and I was just wondering if there is anything out of the norm I should check. The guy I bought it from said is girlfriend owned it and was really good to it. I have not checked anything on it yet and when I unloaded it across the road from my house but didn't let it warm up vary much and it was poping and dying on me. Is that normal for being cold?


Sent from my iPhone using Snowmobile.com Free App
Ak_pride is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-25-2012, 08:42 AM   #2 (permalink)
Registered User
 
Join Date: Aug 2009
Posts: 88
It should have been poping when u were driving it means it was backfiring and if it was dying u might have fouled a plug by not letting it warm up

Sent from my SGH-I747M using Snowmobile.com App
vincanety is offline   Reply With Quote
Old 12-30-2012, 11:08 PM   #3 (permalink)
Registered User
 
Join Date: Dec 2012
Location: Alaska
Posts: 2
Oh I figured out that the popping was a lean popping at idle. It's sucking air in somewhere because it stops doing it when I have the choke half on.


Sent from my iPhone using Snowmobile.com Free App
Ak_pride is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:16 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0