1991 indy 650 won't fire - Snowmobile Forum: Your #1 Snowmobile Forum
http://www.snowmobileforum.com
Go Back   Snowmobile Forum: Your #1 Snowmobile Forum > Specific Snowmobile Forums > Polaris Snowmobiles


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 11-13-2012, 11:33 AM   #1 (permalink)
Registered User
 
polaris_indy22's Avatar
 
Join Date: Aug 2011
Posts: 331
1991 indy 650 won't fire

i have a 1991 indy 650 rxl sks and it sat for 3 years before i got it i had it running last winter but the batter always died so i get a new batter its fully charged reading 12.3v and everything is good there. except now when i pull it it wants to inject gas every time and it won't fire. i pulled all the plugs and checked for gas because i figured they would be soaked with gas. but there was none. i could only smell a little oil and there was oil on the spark plug threads. any ideas? i have been messing with this sled all summer and just had it started a few months ago.

so any help is greatly appreciated.
polaris_indy22 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-13-2012, 01:58 PM   #2 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 32,469
Do you see any spark with the plug laid on the heads?
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 11-13-2012, 02:10 PM   #3 (permalink)
Registered User
 
polaris_indy22's Avatar
 
Join Date: Aug 2011
Posts: 331
Yes u did and it was really good too. Could not. Having enough gas in the tank cause a problem
polaris_indy22 is offline   Reply With Quote
Old 11-13-2012, 02:20 PM   #4 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 32,469
Check to see if it is showing any trouble codes on the ECU.
I would also do a fuel rail pressure test to see if it is getting enough. It should be around 36psi.
If after that you are still having problems with it, contact MrHolmquist as he is the resident expert on the early Poo EFI.
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Old 11-13-2012, 02:26 PM   #5 (permalink)
Registered User
 
polaris_indy22's Avatar
 
Join Date: Aug 2011
Posts: 331
Doesn't it have to be running tyo show codes
polaris_indy22 is offline   Reply With Quote
Old 11-13-2012, 10:00 PM   #6 (permalink)
Registered User
 
polaris_indy22's Avatar
 
Join Date: Aug 2011
Posts: 331
well i have come to the conclusion that im stupid!!! i have figured out my problem. we had the back end sitting on a dolly or better moveability around the garage and that caused the little bit of gas in the tank to run to the front away from the in-tank fuel line end. this cause no gas to be injected when i turned the sled on. as soon as i sat it off of the dolly i could hear it inject the gas. THANK GOD thats all it was!!!. this is the first time ive had it running since i got the exhaust finished. these 650's sound AMAZING!!!

im also working on getting a 79 yamaha enticer 250 reading for the first snow in iowa
polaris_indy22 is offline   Reply With Quote
Old 11-14-2012, 07:16 AM   #7 (permalink)
Super Moderator
 
RJ Gleason's Avatar
 
Join Date: Feb 2005
Location: Groton NY
Posts: 32,469
No, it does not need to be running to show the code, just turn on the key and watch the LED on the ECU.
It should blink once when powered up and once each time you pull the rope.
__________________
Old Cat Rider
'93 Wildcat 700EFI
w/ Comet 108 Pro-4 clutch & 01 ZR skid

'90 Wildcat Project in progress.

Vintage (sorta)
1980 Indy Trail 440 (for sale)
1980 AC Pantera (donor engine to the 90 wildcat)


http://www.dcdrifters.net/


Worshipful Master; F&AM Dryden Lodge# 472
http://www.masonicdryden472.org/

Rules of this forum are strictly enforced!
RJ Gleason is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:07 AM.



Copyright SnowmobileForum.com

Search Engine Friendly URLs by vBSEO 3.6.0