Low Voltage Code - Snowmobile Forum: Your #1 Snowmobile Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-08-2012, 03:20 PM Thread Starter
simy03
 
simy03's Avatar
 
Join Date: Dec 2010
Location: Northfield, MN
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Low Voltage Code

I had my sled re-built last spring after a motor failure at 1500 miles. The dealer accounted it to a simple mechanical failure. I just felt uneasy, so i took it to a different dealer to have a re-flash this morning. While re-flashing, a historic low voltage code came in on one of my injectors. Now I am wondering if this low voltage on my injectors caused my failure. I am assuming a faulty injector would cause a lean condition. How do I go about checking the injectors? Should I be worried, or just run the sled.

Sean Simonson


Past Sleds
'72 Cheetah
'73 Cheetah

'93 XCR 440
'94 XLT
'98 XC 600
'00 XCSP 500 SOLD 8/21/11
'06 Fusion 600 Sold 3/11/11

CURRENT SLED 2010 Polaris Rush 600 bought 11/25/11
simy03 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-14-2012, 11:52 AM Thread Starter
simy03
 
simy03's Avatar
 
Join Date: Dec 2010
Location: Northfield, MN
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
HELLO???? Anyone know anything about the injectors or problems with them????

Sean Simonson


Past Sleds
'72 Cheetah
'73 Cheetah

'93 XCR 440
'94 XLT
'98 XC 600
'00 XCSP 500 SOLD 8/21/11
'06 Fusion 600 Sold 3/11/11

CURRENT SLED 2010 Polaris Rush 600 bought 11/25/11
simy03 is offline  
post #3 of 4 (permalink) Old 11-14-2012, 03:14 PM
Super Moderator
 
BC_Dan's Avatar
 
Join Date: Jan 2004
Location: oregon
Posts: 13,521
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
That's the problem with EFI. You can't do a lot of troubleshooting and have to rely on the dealer. And some of them are pretty clueless about EFI too.

I know when my EFI sleds have issues, I'm at a loss to check and will have to rely on the Polaris Digital Wrench to help diagnose and repair my sled. If the dealer is up on the technology, there's no reason to distrust his findings. If not... that's the big question.

Good luck, we weren't ignoring you, honest

2007 Dragon RMK 700 155", 2008 RMK 600 155", 95 Prowler 550 2-up, Really OLD AC Cheetah

http://www.avalanche.org/accidents.php
BC_Dan is online now  
post #4 of 4 (permalink) Old 11-14-2012, 03:21 PM Thread Starter
simy03
 
simy03's Avatar
 
Join Date: Dec 2010
Location: Northfield, MN
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks for the reply, just don't want to put another $1000 into a new motor again if there is a simple and cheap fix to what my problem is. I'll just keep my fingers crossed that this is an isolated incident. I have owned polaris sleds for the past 20 years, and this is by far the nicest sled I've ever had, and of course the only one I've ever melted down!!!

Sean Simonson


Past Sleds
'72 Cheetah
'73 Cheetah

'93 XCR 440
'94 XLT
'98 XC 600
'00 XCSP 500 SOLD 8/21/11
'06 Fusion 600 Sold 3/11/11

CURRENT SLED 2010 Polaris Rush 600 bought 11/25/11
simy03 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Snowmobile Forum: Your #1 Snowmobile Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome